Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358302 - xterm default bell-style/show-all-if-ambiguous is on
Summary: xterm default bell-style/show-all-if-ambiguous is on
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xterm
Version: 6.8
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Miroslav Lichvar
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 13:16 UTC by Peter Magnusson
Modified: 2017-09-06 10:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-06 10:22:46 UTC


Attachments (Terms of Use)
my normal xterm without any bell. (deleted)
2016-07-20 13:16 UTC, Peter Magnusson
no flags Details
a bell happends (deleted)
2016-07-20 13:16 UTC, Peter Magnusson
no flags Details

Description Peter Magnusson 2016-07-20 13:16:26 UTC
Created attachment 1182112 [details]
my normal xterm without any bell.

https://bugs.centos.org/view.php?id=10948
CentOS people told me to create it here aswell.

Description:	
The update from CentOS 6.7 to 6.8 changes how xterm works.
Now the bell-style is visible and the xterm will invert the colors in an
annoying way when a bell event happends, if you press backspace when you
already are at $ for example. See my screenshots.

centos-6.8-xterm-fail1.png : my normal xterm without any bell.
centos-6.8-xterm-fail2.png : a bell happends

I also noticed that show-all-if-ambiguous if off and you have to press
tab twice to see the dirs available if I do cd .th<tab> if I got
.thumbnails and .thunderbird for example.

Steps To Reproduce:
Always happends.

Additional Information:
Found a workaround that kinda works, if I put
set show-all-if-ambiguous on
set bell-style off
in my .inputrc it fixes the problems. But its not a perfect solution because
it requires a .inputrc on each computer that I will start a xterm on.

If I start xterm with -vb doesnt fix the bell-style problem but it gets
somewhat less annoying.

The xterm binary hasnt changed from 6.7 -> 6.8, Im not sure exactly
where the problem actually are.

Comment 1 Peter Magnusson 2016-07-20 13:16:53 UTC
Created attachment 1182113 [details]
a bell happends

Comment 2 Miroslav Lichvar 2016-07-20 13:26:30 UTC
This is probably the visualBell property of xterm. What does the following command print?

xrdb -query | grep -i xterm

Comment 4 Peter Magnusson 2016-07-20 20:46:02 UTC
Its always:

xterm*background:       #ffffff
xterm*foreground:       #141312
xterm.SimpleMenu*background:    #e0dfde
xterm.SimpleMenu*foreground:    #141312

Comment 5 Miroslav Lichvar 2016-07-21 06:10:16 UTC
Hm, so it looks like it's not enabled by X resources. In the menu that opens when clicking control+middle mouse button, is "Enable Visual Bell" checked?

Comment 6 Peter Magnusson 2016-07-21 11:18:52 UTC
Yes, its enabled.
If I got a .inputrc it isnt.

Comment 7 Miroslav Lichvar 2016-07-21 12:39:52 UTC
Your .inputrc disables the bell in shell, but the xterm visual bell is still enabled, right? The "echo -e '\a'" command can be used to confirm that.

However, I'm not sure how it's getting enabled. From what I understand it can be enabled only by X resources and the -vb command line option. By default it should be disabled, at least that's what I see here.

Comment 8 Peter Magnusson 2016-07-22 08:05:33 UTC
Yes, its still enabled.

It has always been disabled, this is the first time that I got this problem and
I have used xterm as my terminal of choice for about 20 years.

If it matter I start my xterms like this:
xterm -g 80x33 -fg white -bg black -fn 8x13 -rightbar -tn xterm-color
xterm -g 80x33 -fg white -bg black -fn 6x10 -rightbar -tn xterm-color

Comment 9 Peter Magnusson 2016-08-03 16:30:18 UTC
I noticed that emacs have the same problem as xterm.
If you are in a buffer that have no text and press backspace it will also
flash the window just as xterm does. I suspect that this problem has something  
to do with the xorg update that 6.8 got.

Comment 10 Peter Magnusson 2016-08-10 13:45:21 UTC
pidgin have the same issue aswell.

Comment 11 Tomáš Hozza 🤓 2017-09-06 10:22:46 UTC
Red Hat Enterprise Linux 6 transitioned to the Production 3 Phase on May 10, 2017.  During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:
http://redhat.com/rhel/lifecycle

This issue does not appear to meet the inclusion criteria for the Production Phase 3 and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification.  Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com


Note You need to log in before you can comment on or make changes to this bug.