Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358296 - tier: breaking down the monolith processing function tier_migrate_using_query_file()
Summary: tier: breaking down the monolith processing function tier_migrate_using_query...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milind Changire
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 13:01 UTC by Milind Changire
Modified: 2017-03-06 17:21 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-06 17:21:32 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Milind Changire 2016-07-20 13:01:16 UTC
tier: breaking down the monolith processing function tier_migrate_using_query_file()

Comment 1 Vijay Bellur 2016-07-20 13:04:08 UTC
REVIEW: http://review.gluster.org/14957 (cluster/tier: break the monolith processing function) posted (#3) for review on master by Milind Changire (mchangir@redhat.com)

Comment 2 Vijay Bellur 2016-07-21 07:30:06 UTC
REVIEW: http://review.gluster.org/14957 (cluster/tier: break the monolith processing function) posted (#4) for review on master by Milind Changire (mchangir@redhat.com)

Comment 3 Vijay Bellur 2016-07-29 14:25:23 UTC
REVIEW: http://review.gluster.org/14957 (cluster/tier: break the monolith processing function) posted (#5) for review on master by Milind Changire (mchangir@redhat.com)

Comment 4 Vijay Bellur 2016-07-29 15:29:06 UTC
REVIEW: http://review.gluster.org/14957 (cluster/tier: break the monolith processing function) posted (#6) for review on master by Milind Changire (mchangir@redhat.com)

Comment 5 Vijay Bellur 2016-08-09 09:42:08 UTC
REVIEW: http://review.gluster.org/14957 (cluster/tier: break the monolith processing function) posted (#7) for review on master by Milind Changire (mchangir@redhat.com)

Comment 6 Vijay Bellur 2016-08-09 18:30:17 UTC
REVIEW: http://review.gluster.org/14957 (cluster/tier: break the monolith processing function) posted (#8) for review on master by Milind Changire (mchangir@redhat.com)

Comment 7 Vijay Bellur 2016-08-17 09:25:29 UTC
REVIEW: http://review.gluster.org/14957 (cluster/tier: break the monolith processing function) posted (#9) for review on master by Milind Changire (mchangir@redhat.com)

Comment 8 Worker Ant 2016-10-25 13:32:56 UTC
REVIEW: http://review.gluster.org/14957 (cluster/tier: break the monolith processing function) posted (#10) for review on master by Dan Lambright (dlambrig@redhat.com)

Comment 9 Worker Ant 2016-10-25 15:53:19 UTC
REVIEW: http://review.gluster.org/14957 (cluster/tier: break the monolith processing function) posted (#11) for review on master by Milind Changire (mchangir@redhat.com)

Comment 10 Worker Ant 2016-10-26 20:53:10 UTC
COMMIT: http://review.gluster.org/14957 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit b87848617b9842e7943f67596a441e4c052c3b81
Author: Milind Changire <mchangir@redhat.com>
Date:   Tue Jul 19 16:20:15 2016 +0530

    cluster/tier: break the monolith processing function
    
    Break tier_migrate_using_query_file() into a more manageable
    tier_migrate_link() and helpers.
    
    Change-Id: I5eb2d2cff9e7a2a2da567c3c4c2d53aab195f477
    BUG: 1358296
    Signed-off-by: Milind Changire <mchangir@redhat.com>
    Reviewed-on: http://review.gluster.org/14957
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>

Comment 11 Shyamsundar 2017-03-06 17:21:32 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.