Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358291 - [RFE] Import a disk from domain who was attached to a VM before the domain detached from the environment should register back to the VM
Summary: [RFE] Import a disk from domain who was attached to a VM before the domain de...
Keywords:
Status: CLOSED DUPLICATE of bug 1108904
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RFEs
Version: 4.0.1.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ---
: ---
Assignee: Maor
QA Contact: Gil Klein
URL:
Whiteboard:
Depends On: 1302780 1358171
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 12:37 UTC by Eyal Shenitzky
Modified: 2016-11-15 00:39 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-15 00:15:32 UTC
oVirt Team: Storage
amureini: ovirt-future?
eshenitz: planning_ack?
eshenitz: devel_ack?
eshenitz: testing_ack?


Attachments (Terms of Use)

Description Eyal Shenitzky 2016-07-20 12:37:05 UTC
Description of problem:

In advance to https://bugzilla.redhat.com/show_bug.cgi?id=1358290.

In environment with VM with 2 attached disks, one on domain A and the other on domain B,
When detaching domain B, the second disk (on domain B) of the VM becomes unregistered from the system, but the VM remains.
When attaching the domain B back to the environment, we have the option to register the mentioned disk back, and according to the feature page (http://www.ovirt.org/release/4.0.0/) it should be registered as floating disk.

Register a disk who was attached to a VM before the storage domain detached from the environment, should be automatically attached to the VM when registered by the user in case the VM is still exist.

This can be achieved by using - 
https://bugzilla.redhat.com/show_bug.cgi?id=1357616

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Allon Mureinik 2016-07-21 12:43:38 UTC
Should be considered along with bug 1358171.

Comment 3 Maor 2016-11-15 00:15:32 UTC
This scenario is not that simple since the VM's snapshots might be changed and attaching the disk once the VM's snapshots were changed will make it unsync.
For example VM1 with disk1(on storage1) and disk2 (on storage2) have 2 snapshots.
Now we detach storage1 and we are left with VM1 with only disk2.
If the user will remove those 2 snapshots on VM1, and will try to import storage1 and attach disk1 to it the engine will never be aware of those two snapshots that disk1 still has.
This scenario should be considered as part of https://bugzilla.redhat.com/show_bug.cgi?id=1108904 solution.
Therefore closing it as duplicate.

*** This bug has been marked as a duplicate of bug 1108904 ***


Note You need to log in before you can comment on or make changes to this bug.