Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358281 - cannot install pyldb
Summary: cannot install pyldb
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libldb
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Hrozek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 12:20 UTC by Jakub Hrozek
Modified: 2016-07-22 14:57 UTC (History)
6 users (show)

Fixed In Version: libldb-1.1.26-4.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-22 14:57:30 UTC


Attachments (Terms of Use)
Spec change (deleted)
2016-07-21 18:32 UTC, Lukas Slebodnik
sgallagh: review+
Details | Diff

Description Jakub Hrozek 2016-07-20 12:20:11 UTC
Description of problem:
14:04 < lslebodn> jhrozek: you broke rawhide with latest libldb
14:04 < lslebodn> dnf install 'pyldb" fails because there is not such provides in spec
14:05 < lslebodn> there is only 'pyldb(x86-64)'. So dnf install 'pyldb(x86-64)' works
14:05 < lslebodn> but it breaks build of samba and sssd
14:06 < jhrozek> lslebodn: file a bug
14:07 < lslebodn> IMHO, it should be enough to remove "%{?_isa}" from provides, obsoletes but it would be better to consult with pviktori or someone else experienced with fedora packaging

Comment 1 Jakub Hrozek 2016-07-20 12:21:26 UTC
Petr, does removing isa from provides sound like a good fix to you?

Comment 2 Lukas Slebodnik 2016-07-20 12:26:36 UTC
http://koji.fedoraproject.org/koji/buildinfo?buildID=783592
https://kojipkgs.fedoraproject.org//work/tasks/532/14950532/root.log



[root@b766bf8307b5 ~]# dnf install pyldb
Last metadata expiration check: 0:02:13 ago on Wed Jul 20 12:23:57 2016.
No package pyldb available.
Error: Unable to find a match.


[root@b766bf8307b5 ~]# dnf install 'pyldb(x86-64)'
Last metadata expiration check: 0:02:15 ago on Wed Jul 20 12:23:57 2016.
Dependencies resolved.
================================================================================
 Package             Arch           Version               Repository       Size
================================================================================
Installing:
 libldb              x86_64         1.1.26-2.fc25         rawhide         132 k
 libtalloc           x86_64         2.1.7-1.fc25          rawhide          44 k
 libtdb              x86_64         1.3.9-1.fc25          rawhide          49 k
 libtevent           x86_64         0.9.28-2.fc25         rawhide          36 k
 python-libs         x86_64         2.7.12-1.fc25         rawhide         5.8 M
 python-tdb          x86_64         1.3.9-1.fc25          rawhide          23 k
 python2-ldb         x86_64         1.1.26-2.fc25         rawhide          47 k

Transaction Summary
================================================================================
Install  7 Packages

Comment 3 Stephen Gallagher 2016-07-20 13:19:47 UTC
I think you want to have both `Provides: pyldb` and `Provides: pyldb%{?_isa}`, but only `Obsoletes: pyldb < 1.1.26-1` (also, Obsoletes must be exact versions. If you carry it with an increasing value, it can cause problems with upgrades from older versions).

Lastly, I'd recommend backporting this change to F23 and F24, if only because it'll make upgrades complicated if 1.1.27 is released (because we'll have to change the Obsoletes again).

Comment 4 Lukas Slebodnik 2016-07-20 14:46:14 UTC
(In reply to Stephen Gallagher from comment #3)
> Lastly, I'd recommend backporting this change to F23 and F24, if only
> because it'll make upgrades complicated if 1.1.27 is released (because we'll
> have to change the Obsoletes again).
I am strictly against back-porting to the stable versions of fedora.

Because stable repo would still contain "pyldb" and updates would contain "python2-ldb". But "dnf install pyldb" will install package from stable repo and not latest version using provides. BZ1096506

Comment 5 Lukas Slebodnik 2016-07-21 18:32:23 UTC
Created attachment 1182645 [details]
Spec change

Attached is a patch which Stephen proposed.

Comment 6 Jakub Hrozek 2016-07-22 14:57:30 UTC
Thanks for the patch and the review!

Built for rawhide in libldb-1.1.26-4.fc25


Note You need to log in before you can comment on or make changes to this bug.