Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 135828 - "Network Configuration" help should warn about PCMCIA and "Active on Boot"
Summary: "Network Configuration" help should warn about PCMCIA and "Active on Boot"
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda-help
Version: rawhide
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Mike McLean
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
Reported: 2004-10-15 09:57 UTC by Barry K. Nathan
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2006-06-07 18:06:02 UTC

Attachments (Terms of Use)

Description Barry K. Nathan 2004-10-15 09:57:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a4)

Description of problem:
I just happened to notice this dialog box, when I tried to set no
network devices to be "Active on Boot":

---begin quote---
Error With Data

You have no active network devices.  Your system will not be
able to communicate over a network by default without at least
one device active.

NOTE: If you have a PCMCIA-based network adapter you should leave it
inactive at this point. When you reboot your system the adapter will
be activated automatically.
---end quote---

The thing is, if I hadn't tried deactivating all network devices on
this system, I *never* would have seen anything in the installer about
keeping "Active on Boot" disabled for PCMCIA devices.

IMO the "Network Configuration" help should mention this somewhere.
Unless I'm *really* tired or something, I couldn't find it mentioned
anywhere in that help text.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start an fc-devel install.
2. At the "Network Configuration" screen, read through the help text.
3. Uncheck "Active on Boot" for all network devices.
4. Click "Next".
5. Read the dialog box.

Actual Results:  PCMCIA "Active on Boot" gotcha is mentioned only in
the dialog box.

Expected Results:  It should be mentioned in the "Network
Configuration" help text too.

Additional info:

I'm aware that it's (almost certainly) too late to fix this for FC3,
but if it could be fixed for FC4 I'd appreciate it. (BTW, is it too
late to fix this for RHEL4?)

Comment 1 Jeremy Katz 2005-09-21 18:22:44 UTC
I'm not sure how relevant some of this is with the new way PCMCIA is handled. 
Chris -- can you take a look

Comment 2 Chris Lumens 2006-06-07 18:06:02 UTC
This shouldn't be a problem with the more recent PCMCIA system.  In addition,
we've removed the help panel entirely because it wasn't ever very helpful and I
have removed the PCMCIA-specific portion of text from that error message so it
won't be misleading.

Note You need to log in before you can comment on or make changes to this bug.