Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358268 - Trash translator fails to create 'internal_op' directory under already existing trash directory
Summary: Trash translator fails to create 'internal_op' directory under already existi...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: trash-xlator
Version: 3.7.13
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jiffin
QA Contact:
URL:
Whiteboard:
Depends On: 1356804 1357397
Blocks: glusterfs-3.7.15
TreeView+ depends on / blocked
 
Reported: 2016-07-20 11:57 UTC by Jiffin
Modified: 2016-09-01 09:32 UTC (History)
9 users (show)

Fixed In Version: glusterfs-3.7.15
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1357397
Environment:
Last Closed: 2016-09-01 09:20:35 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-07-20 12:06:22 UTC
REVIEW: http://review.gluster.org/14966 (xlator/trash : append '/' at the end in trash_notify_lookup_cbk) posted (#1) for review on release-3.7 by jiffin tony Thottan (jthottan@redhat.com)

Comment 2 Vijay Bellur 2016-08-12 10:04:55 UTC
REVIEW: http://review.gluster.org/14966 (xlator/trash : append '/' at the end in trash_notify_lookup_cbk) posted (#2) for review on release-3.7 by Oleksandr Natalenko (oleksandr@natalenko.name)

Comment 3 Vijay Bellur 2016-08-16 06:23:17 UTC
COMMIT: http://review.gluster.org/14966 committed in release-3.7 by Kaushal M (kaushal@redhat.com) 
------
commit cfba6098a4ef8c672969d69678fcdca7c8bb6399
Author: Jiffin Tony Thottan <jthottan@redhat.com>
Date:   Mon Jul 18 11:12:43 2016 +0530

    xlator/trash : append '/' at the end in trash_notify_lookup_cbk
    
    In the notify function in trash xlator, a lookup is performed
    to obtain path of old trash directory. The result usually contains
    path without '/' at the end. The trash xlator maintains expects
    '/' at the end for the values such as 'old trash dir' and
    'new trash dir'. Otherwise certian checks in the code will fail.
    
    Upstream reference:
    >Change-Id: I89e02e4b249314fb6536297f959865feee182c83
    >BUG: 1357397
    >Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    >Reviewed-on: http://review.gluster.org/14938
    >Smoke: Gluster Build System <jenkins@build.gluster.org>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    >Reviewed-by: Anoop C S <anoopcs@redhat.com>
    >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    >Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    >(cherry picked from commit d90307c1b0245e0e6a39044a28819cde520a100c)
    
    Change-Id: I89e02e4b249314fb6536297f959865feee182c83
    BUG: 1358268
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Signed-off-by: Oleksandr Natalenko <oleksandr@natalenko.name>
    Reviewed-on: http://review.gluster.org/14966
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 4 Kaushal 2016-09-01 09:20:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.15, please open a new bug report.

glusterfs-3.7.15 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-September/050714.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 5 Kaushal 2016-09-01 09:32:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.15, please open a new bug report.

glusterfs-3.7.15 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-September/050714.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.