Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358227 - [CLI] Autocompletion for get methods suggesting incorrect fields
Summary: [CLI] Autocompletion for get methods suggesting incorrect fields
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli
Version: 3.6.8
Hardware: x86_64
OS: All
unspecified
medium
Target Milestone: ovirt-3.6.9
: 3.6.9
Assignee: Juan Hernández
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 10:05 UTC by Lukas Svaty
Modified: 2016-09-21 17:56 UTC (History)
9 users (show)

Fixed In Version: rhevm-cli-3.6.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-21 17:56:17 UTC
oVirt Team: Infra


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1920 normal SHIPPED_LIVE 3.6.9 - rhevm-cli bug fix and enhancement update 2016-09-21 21:52:26 UTC
oVirt gerrit 61095 master MERGED cli: Ignore "id" and "name" options for the "show" command 2016-08-30 07:39:49 UTC
oVirt gerrit 62676 cli_3.6 MERGED cli: Ignore "id" and "name" options for the "show" command 2016-08-22 14:42:56 UTC

Description Lukas Svaty 2016-07-20 10:05:34 UTC
Description of problem:
Autocompletion for show method is suggesting incorrect parameters within ovirt-shell.

Suggested command:
show datacenter --name Default

Correct command:
show datacenter Default

Parameters --name and --id are suggested but incorrect

Version-Release number of selected component (if applicable):
rhevm-cli-3.6.8.1-1.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Try to show datacenter info based on autocomplete <tab> suggestions

Actual results:
Unclear help

Expected results:
No experience needed to do these operations with help.

Comment 4 Lucie Leistnerova 2016-08-31 08:54:35 UTC
nothing suggested for show datacenter

verified in rhevm-cli-3.6.9.0-1.el6ev.noarch

Comment 6 errata-xmlrpc 2016-09-21 17:56:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1920.html


Note You need to log in before you can comment on or make changes to this bug.