Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358195 - Fix spurious failure of tests/bugs/glusterd/bug-1111041.t
Summary: Fix spurious failure of tests/bugs/glusterd/bug-1111041.t
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1358590 1358591
TreeView+ depends on / blocked
 
Reported: 2016-07-20 09:33 UTC by Avra Sengupta
Modified: 2017-03-27 18:15 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1358590 1358591 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:15:34 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Avra Sengupta 2016-07-20 09:33:59 UTC
Description of problem:
On a faster machine the ps check is returning two pids including the glusterfsd process's right after that process forks.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vijay Bellur 2016-07-20 09:38:00 UTC
REVIEW: http://review.gluster.org/14963 (tests: Fix spurious failure of tests/bugs/glusterd/bug-1111041.t) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 2 Vijay Bellur 2016-07-20 10:02:47 UTC
REVIEW: http://review.gluster.org/14963 (tests: Fix spurious failure of tests/bugs/glusterd/bug-1111041.t) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 3 Vijay Bellur 2016-07-20 15:21:53 UTC
COMMIT: http://review.gluster.org/14963 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit be69510e670cb5ee893399ca1d7e7d2a60a9483c
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Wed Jul 20 15:04:01 2016 +0530

    tests: Fix spurious failure of tests/bugs/glusterd/bug-1111041.t
    
    On a faster machine the ps check was returning two pids,
    including the glusterfsd process's pid, right after that,
    process forked. Hence removing that ps, as for the scope
    of this test, verifying the snapd pid from the status
    command itself is enough.
    
    Change-Id: I8bd8fc4ea406d96e3a47f952cfe44560b615dbe6
    BUG: 1358195
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/14963
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 4 Shyamsundar 2017-03-27 18:15:34 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.