Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358178 - [abrt] virt-manager: in(): python2.7 killed by SIGABRT
Summary: [abrt] virt-manager: in(): python2.7 killed by SIGABRT
Keywords:
Status: CLOSED DUPLICATE of bug 1357200
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:d24ddc764bef3bf29cab5e517f1...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 09:02 UTC by Kamil Páral
Modified: 2016-07-20 12:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-20 12:45:56 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2016-07-20 09:02 UTC, Kamil Páral
no flags Details
File: cgroup (deleted)
2016-07-20 09:02 UTC, Kamil Páral
no flags Details
File: core_backtrace (deleted)
2016-07-20 09:02 UTC, Kamil Páral
no flags Details
File: dso_list (deleted)
2016-07-20 09:02 UTC, Kamil Páral
no flags Details
File: environ (deleted)
2016-07-20 09:02 UTC, Kamil Páral
no flags Details
File: limits (deleted)
2016-07-20 09:02 UTC, Kamil Páral
no flags Details
File: maps (deleted)
2016-07-20 09:02 UTC, Kamil Páral
no flags Details
File: mountinfo (deleted)
2016-07-20 09:02 UTC, Kamil Páral
no flags Details
File: namespaces (deleted)
2016-07-20 09:02 UTC, Kamil Páral
no flags Details
File: open_fds (deleted)
2016-07-20 09:02 UTC, Kamil Páral
no flags Details
File: proc_pid_status (deleted)
2016-07-20 09:02 UTC, Kamil Páral
no flags Details
File: var_log_messages (deleted)
2016-07-20 09:02 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2016-07-20 09:02:15 UTC
Description of problem:
I see this crash every time I try to start any VM from virt-manager. It immediately crashes. However, I can connect to that VM using virt-viewer afterwards. I can also control my VMs using virsh. The problem seems to be related only to virt-manager.

Version-Release number of selected component:
virt-manager-1.4.0-3.fc24

Additional info:
reporter:       libreport-2.7.2
backtrace_rating: 3
cmdline:        /usr/bin/python2 /usr/share/virt-manager/virt-manager
crash_function: in
executable:     /usr/bin/python2.7
global_pid:     6101
kernel:         4.6.4-301.fc24.x86_64
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 0 (10 frames)
 #2 0x00007f096ce12acb in
 #3 avcodec_alloc_context3
 #4 gst_ffmpeg_cfg_install_property at gstavcfg.c:732
 #5 gst_ffmpegvidenc_class_init at gstavvidenc.c:225
 #6 g_type_class_ref at gtype.c:2241
 #8 gst_element_register at gstelementfactory.c:243
 #9 gst_ffmpegvidenc_register at gstavvidenc.c:1009
 #10 plugin_init at gstav.c:158
 #11 gst_plugin_register_func at gstplugin.c:523
 #12 _priv_gst_plugin_load_file_for_registry at gstplugin.c:826

Comment 1 Kamil Páral 2016-07-20 09:02:25 UTC
Created attachment 1181969 [details]
File: backtrace

Comment 2 Kamil Páral 2016-07-20 09:02:27 UTC
Created attachment 1181970 [details]
File: cgroup

Comment 3 Kamil Páral 2016-07-20 09:02:29 UTC
Created attachment 1181971 [details]
File: core_backtrace

Comment 4 Kamil Páral 2016-07-20 09:02:31 UTC
Created attachment 1181972 [details]
File: dso_list

Comment 5 Kamil Páral 2016-07-20 09:02:33 UTC
Created attachment 1181973 [details]
File: environ

Comment 6 Kamil Páral 2016-07-20 09:02:34 UTC
Created attachment 1181974 [details]
File: limits

Comment 7 Kamil Páral 2016-07-20 09:02:38 UTC
Created attachment 1181975 [details]
File: maps

Comment 8 Kamil Páral 2016-07-20 09:02:40 UTC
Created attachment 1181976 [details]
File: mountinfo

Comment 9 Kamil Páral 2016-07-20 09:02:42 UTC
Created attachment 1181977 [details]
File: namespaces

Comment 10 Kamil Páral 2016-07-20 09:02:44 UTC
Created attachment 1181978 [details]
File: open_fds

Comment 11 Kamil Páral 2016-07-20 09:02:45 UTC
Created attachment 1181979 [details]
File: proc_pid_status

Comment 12 Kamil Páral 2016-07-20 09:02:47 UTC
Created attachment 1181980 [details]
File: var_log_messages

Comment 13 Kamil Páral 2016-07-20 09:04:01 UTC
In system journal I see these errors:

Jul 20 10:55:44 dryad virtlogd[6258]: End of file while reading data: Input/output error
Jul 20 10:55:44 dryad abrt-hook-ccpp[7593]: Process 7476 (python2.7) of user 1000 killed by SIGABRT - dumping core
Jul 20 10:55:45 dryad libvirtd[7363]: End of file while reading data: Input/output error
Jul 20 10:55:45 dryad libvirtd[7492]: End of file while reading data: Input/output error
Jul 20 10:55:45 dryad abrt-server[7594]: Deleting problem directory ccpp-2016-07-20-10:55:44-7476 (dup of ccpp-2016-07-20-10:50:44-6101)

Comment 14 Kamil Páral 2016-07-20 09:29:11 UTC
I removed ffmpeg and it stopped crashing. Then I installed it back and it was still not crashing. I rebooted and it wasn't crashing. So I have the same system state as before, but it's not crashing now, I can't reproduce the problem. I ... don't know.

Comment 15 Cole Robinson 2016-07-20 12:45:56 UTC

*** This bug has been marked as a duplicate of bug 1357200 ***


Note You need to log in before you can comment on or make changes to this bug.