Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358158 - Update 1.3.3-2.fc24 → libinput-1.4.0-1.fc24 breaks keyboard layout on all Gtk+ 3.x applications with wayland backend
Summary: Update 1.3.3-2.fc24 → libinput-1.4.0-1.fc24 breaks keyboard layout on all Gtk...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: libinput
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 08:09 UTC by Christian Stadelmann
Modified: 2016-07-20 09:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-20 09:07:22 UTC


Attachments (Terms of Use)

Description Christian Stadelmann 2016-07-20 08:09:59 UTC
I have three keyboard layouts listed. Firefox and other x11 applications behave as they should using the correct layout which is set in gnome-shell (top right "system tray") and gnome-control-center. Gtk3/wayland applications use the secondary or tertiary layout.

Affected applications: All Gtk+ 3.x applications with wayland backend

Not affected: Firefox (Gtk+ 3.20 but with x11 backend), several Gtk+ 2.x applications, Qt4 applications; gnome-shell itself

Version-Release number of selected component (if applicable):
libinput-1.4.0-1.fc24

How reproducible:
always for me on one machine, had no chance to test somewhere else yet.

Steps to Reproduce:
1. have at least two (in my case: three) keyboard layouts configured in gnome-shell (top right "system tray") or gnome-control-center.
2. update to libinput 1.4.0
3. use desktop as you would normally

Actual results:
In Gtk+ applications with wayland backend, keyboard layout is set to secondary or tertiary layout. All other applications behave correctly

Expected results:
All applications should respect the configured keyboard layout

Additional info:

$ localectl
   System Locale: LANG=de_DE.UTF-8
       VC Keymap: de-neo
      X11 Layout: de,de
     X11 Variant: neo,nodeadkeys
     X11 Options: grp:sclk_toggle

Comment 1 Christian Stadelmann 2016-07-20 08:17:52 UTC
I don't know why this issue was present at first time, but I can't reproduce it any more after another reboot and upgrade.

You might want to close this report as I can't reproduce it and have no clue how to hunt it down.

Comment 2 Peter Hutterer 2016-07-20 09:07:22 UTC
ok, thanks. I'll close it, please reopen when you can reproduce it.

basically: libinput does not do layouts at all (handled at a higher level) and we didn't have any keyboard code change in the 1.4 release. so I don't think whatever it was was caused by libinput.


Note You need to log in before you can comment on or make changes to this bug.