Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358114 - tests: ./tests/bitrot/br-stub.t fails intermittently
Summary: tests: ./tests/bitrot/br-stub.t fails intermittently
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1360578 1360579
TreeView+ depends on / blocked
 
Reported: 2016-07-20 06:04 UTC by Kotresh HR
Modified: 2017-03-08 09:32 UTC (History)
1 user (show)

Fixed In Version: v3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1360578 (view as bug list)
Environment:
Last Closed: 2017-03-08 09:32:13 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2016-07-20 06:04:01 UTC
Description of problem:
./tests/bitrot/br-stub.t fails intermittently in regression.

Version-Release number of selected component (if applicable):
mainline

How reproducible:
Intermittently

Steps to Reproduce:
Regression run

Actual results:
./tests/bitrot/br-stub.t fails occasionally

Expected results:
./tests/bitrot/br-stub.t should always pass

Additional info:

Comment 1 Vijay Bellur 2016-07-20 06:18:57 UTC
REVIEW: http://review.gluster.org/14960 (tests: Fix spurious failure of br-stub.t) posted (#1) for review on master by Kotresh HR (khiremat@redhat.com)

Comment 2 Vijay Bellur 2016-07-20 07:09:01 UTC
REVIEW: http://review.gluster.org/14961 (tests: Wait for a while for gluster-NFS server to start) posted (#1) for review on master by soumya k (skoduri@redhat.com)

Comment 3 Vijay Bellur 2016-07-21 14:25:34 UTC
COMMIT: http://review.gluster.org/14960 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit f4bbe515097e0149c78c1fc1bae9fb90928e7cd8
Author: Kotresh HR <khiremat@redhat.com>
Date:   Wed Jul 20 11:36:31 2016 +0530

    tests: Fix spurious failure of br-stub.t
    
    The nfs mount fails occasionally in ./tests/bitrot/br-stub.t.
    The reason being nfs mount is attempted before the gluster
    nfs has come up. It is a race and hence happens occasionally.
    The patch fixes it by waiting for nfs server to come up
    before mount.
    
    Thanks skoduri@redhat.com for root causing it.
    
    Change-Id: I3adbf2363514635785c02b1478733095ad0b74cf
    BUG: 1358114
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/14960
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Poornima G <pgurusid@redhat.com>
    Reviewed-by: soumya k <skoduri@redhat.com>
    Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>


Note You need to log in before you can comment on or make changes to this bug.