Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358101 - [quick install] remove OSE 3.1, OSE 3.0 and AEP support
Summary: [quick install] remove OSE 3.1, OSE 3.0 and AEP support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.2.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Samuel Munilla
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 04:28 UTC by Anping Li
Modified: 2017-03-08 18:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
The installation options for OpenShift Enterprise 3.1, OpenShift Enterprise 3.0, and Atomic Enterprise Platform have been removed from the OpenShift Enterprise 3.2 version of the quick installer. To install OpenShift Enterprise 3.1 or 3.0, use the atomic-openshift-utils package from the respective product version's repository.
Clone Of:
Environment:
Last Closed: 2016-08-18 19:29:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1639 normal SHIPPED_LIVE OpenShift Enterprise atomic-openshift-utils bug fix and enhancement update 2016-08-18 23:26:45 UTC

Description Anping Li 2016-07-20 04:28:33 UTC
Description of problem:
Remove 3.1, 3.0 and AEP from atomic-openshift-installer due to atomic-openshift-utils 3.2 don't support.


Version-Release number of selected component (if applicable):
OSE 3.2
atomic-openshift-utils-3.2.13

How reproducible:
always

Steps to Reproduce:
1. atomic-openshift-installer install
2.
3.

Actual results:
It prompt we can installed 3.1, 3.0 and AEP, In fact, installer will fail.


#atomic-openshift-installer install
Welcome to the OpenShift Enterprise 3 installation.

Please confirm that following prerequisites have been met:

<--skip-->
Which variant would you like to install?


(1) OpenShift Enterprise 3.2
(2) OpenShift Enterprise 3.1
(3) OpenShift Enterprise 3.0
(4) Atomic Enterprise Platform 3.2
(5) Atomic Enterprise Platform 3.1

Choose a variant from above:  [1]: 2
<--skip--->
<--skip--->


TASK: [docker | Get current installed Docker version] ************************* 
ok: [host4master.example.com]

TASK: [docker | Error out if Docker pre-installed but too old] **************** 
failed: [host4master.example.com] => {"failed": true}
msg: Docker 1.8.2 is installed, but >= 1.9.1 is required.

FATAL: all hosts have already failed -- aborting

PLAY RECAP ******************************************************************** 
           to retry, use: --limit @/root/config.retry

host4master.example.com    : ok=132  changed=15   unreachable=0    failed=1   
host4node.example.com      : ok=48   changed=2    unreachable=0    failed=0   
localhost                  : ok=12   changed=0    unreachable=0    failed=0 

Expected results:


Additional info:

Comment 1 Samuel Munilla 2016-07-30 14:07:45 UTC
Opened https://github.com/openshift/openshift-ansible/pull/2242 to address this.

Comment 3 Alex Jia 2016-08-05 03:28:08 UTC
We need to build a new RPM packge w/ above patch in Comment 1, because the issue hasn't been fixed in atomic-openshift-utils-3.2.13-1.git.0.0afa976.el7.noarch.

Comment 4 Anping Li 2016-08-05 09:31:55 UTC
Those options are removed at atomic-openshift-utils-3.2.18-1.git.0.2015d79.el7.noarch.

Comment 6 errata-xmlrpc 2016-08-18 19:29:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1639


Note You need to log in before you can comment on or make changes to this bug.