Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358094 - Guest hang when migrate from OVS to macvtap backend.
Summary: Guest hang when migrate from OVS to macvtap backend.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Vlad Yasevich
QA Contact: xiywang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 03:12 UTC by weliao
Modified: 2017-07-03 07:58 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-15 01:17:05 UTC


Attachments (Terms of Use)

Description weliao 2016-07-20 03:12:40 UTC
Description of problem:
Do magrate from OVS backend to macvtap backend,Windows10 X86 guest hang.

Version-Release number of selected component (if applicable):
Host:
3.10.0-469.el7.x86_64
qemu-kvm-rhev-2.6.0-13.el7.x86_64
openvswitch-2.5.0-3.el7.x86_64
Guest:
Windows10 x86

How reproducible:
100%

Steps to Reproduce:
1.Boot a guest w/ vhost=on in the src host(OVS backend).
/usr/libexec/qemu-kvm -name win10_x86 -M pc -cpu SandyBridge -m 4096 -realtime mlock=off -smp 4,maxcpus=6,cores=2,threads=1,sockets=2 -drive file=/mnt/win10_86.qcow2,if=none,id=drive-virtio-disk0,format=qcow2 -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x7,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,id=hostnet0,vhost=on  -device virtio-net-pci,netdev=hostnet0,id=net0,mac=8e:f0:1c:9e:4f:6b,bus=pci.0,addr=0x3,disable-legacy=off,disable-modern=on,status=on -device qxl-vga,id=video0,ram_size=67108864,vram_size=67108864,vgamem_mb=16,bus=pci.0,addr=0x2 -spice port=5900,disable-ticketing, -monitor stdio  -boot menu=on  -qmp tcp:0:4444,server,nowait
2.Launch the listening mode guest w/ vhost=on in the dst host, and the dst host is configured w/ macvtap VEPA backend.
/usr/libexec/qemu-kvm -name win10_x86 -M pc -cpu SandyBridge -m 4096 -realtime mlock=off -smp 4,maxcpus=6,cores=2,threads=1,sockets=2 -drive file=/mnt/win10_86.qcow2,if=none,id=drive-virtio-disk0,format=qcow2 -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x7,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,id=hostnet0,vhost=on,fd=9  9<>/dev/tap10  -device virtio-net-pci,netdev=hostnet0,id=net0,mac=8e:f0:1c:9e:4f:6b,bus=pci.0,addr=0x3,disable-legacy=off,disable-modern=on,status=on -device qxl-vga,id=video0,ram_size=67108864,vram_size=67108864,vgamem_mb=16,bus=pci.0,addr=0x2 -spice port=5900,disable-ticketing, -monitor stdio -boot menu=on     -qmp tcp:0:5555,server,nowait -qmp tcp:0:4444,server,nowait -incoming tcp:0:5800
3.Do migrate
(qemu) migrate -d tcp:10.66.8.254:5800    
(qemu) migrate_set_speed 100G

Actual results:
Guest hang.

Expected results:
Guest work well.

Additional info:
also tested rhel7.3 guest, no this issue, when migrate from macvtap backend to OVS backend, no this issue.

Comment 3 Vlad Yasevich 2017-02-27 13:45:32 UTC
Hmm.  Trying migration on the localhost, it didn't happen.  Will try 2 different hosts.

I am wondering if may be it's some kind of duplicate mac detection in windows...

-vlad

Comment 4 Vlad Yasevich 2017-03-26 02:08:24 UTC
Hello QE

I am having issues reproducing this on the latest rhel7 with the latest virtio-win package.

Could you please try reproducing this and if you can, can I please get access to the systems so I can see what's happening.

Thanks you
Vlad

Comment 5 xiywang 2017-04-10 03:37:31 UTC
Hi Vlad,

I've tested follow the test steps listed in comment 1 but could not reproduce this issue.

Here are the version of rpm packages I used:
qemu-kvm-rhev-2.8.0-6.el7.x86_64
openvswitch-2.6.1-15.git20161206.el7fdp.x86_64
kernel-3.10.0-603.el7.x86_64

Guest:
Win10 x86_64

It seems we both could not reproduce this. Feel free to let me know if I can provide any more help.

Thanks,
Xiyue

Comment 6 Vlad Yasevich 2017-04-15 01:17:05 UTC
QE and DEV can't reproduce.  Closing.


Note You need to log in before you can comment on or make changes to this bug.