Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358091 - Windows snap to the wrong position when the bottom panel is set to auto-hide
Summary: Windows snap to the wrong position when the bottom panel is set to auto-hide
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kwin
Version: 24
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Vrátil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 02:48 UTC by 3ndymion
Modified: 2016-07-20 12:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-20 12:16:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 365892 None None None 2016-07-20 12:16:06 UTC

Description 3ndymion 2016-07-20 02:48:48 UTC
Description of problem:
1 year later... this problem was never fixed.  Now in Fedora 24.  Bug 1263547

This bug happens when the task manager / bottom panel is set to auto-hide.  When moving any window towards the bottom of the screen, the window will snap to the position that the panel would be at if the panel was showing (not hiding).  If the panel is currently hiding, windows should not snap to the position that the panel would be at when the panel is open.  Or, in other words, windows should not snap to something that's not there.


Version-Release number of selected component (if applicable):


How reproducible:
Always.


Steps to Reproduce:
1. Set panel to auto-hide.
2. Move windows towards the panel once it is hidden.
3.


Actual results:
Window snaps to the position that the panel was at when it was showing, even if the panel is already hiding.


Expected results:
Window will continue to move freely towards the edge of the screen.  Since panel is hiding, it will only snap to the edge of the screen.


Additional info:

Comment 1 Rex Dieter 2016-07-20 11:15:42 UTC
I'd suggest you report this upstream @ bugs.kde.org  (we downstream in fedora are generally not in a position to fix it ourselves).

Comment 2 3ndymion 2016-07-20 11:56:14 UTC
(In reply to Rex Dieter from comment #1)
> I'd suggest you report this upstream @ bugs.kde.org  (we downstream in
> fedora are generally not in a position to fix it ourselves).

Oh, my apologies.  I'll report to them.  Thank you.

Comment 3 Rex Dieter 2016-07-20 11:57:44 UTC
Please do report back the bug #, so that we can continue tracking the issue, thanks!

Comment 4 3ndymion 2016-07-20 12:11:29 UTC
Cool, thanks!!!  : )

This is now KDE Bugtracking System Bug 365892
https://bugs.kde.org/show_bug.cgi?id=365892

Comment 5 Rex Dieter 2016-07-20 12:16:06 UTC
thanks


Note You need to log in before you can comment on or make changes to this bug.