Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358075 - 4.6.3-300.fc24 gets wrong resolution on external monitor on thinkpad T440
Summary: 4.6.3-300.fc24 gets wrong resolution on external monitor on thinkpad T440
Keywords:
Status: CLOSED DUPLICATE of bug 1358074
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 24
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 02:14 UTC by Fabio Olive Leite
Modified: 2016-07-21 16:16 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-21 16:16:26 UTC


Attachments (Terms of Use)

Description Fabio Olive Leite 2016-07-20 02:14:22 UTC
When booting kernel-4.6.3-300.fc24.x86_64 I'm not able to select my external monitor's normal ultrawide resolution of 2560x1080, as the highest resolution available with that kernel (in both Gnome and Cinnamon display settings) is 1920x1080.

This has always worked fine on Fedora 23, up to kernel-4.5.7-202.fc23.x86_64, at which point I upgraded via dnf to Fedora 24, so I went directly to the current 4.6.3-300.fc24 kernel and was greeted with a distorted image.  Booting the Fedora 24 GA kernel from the Live image (4.5.5-something) also works fine, it is really just 4.6.3-300.fc24 that for some reason detects something wrong.

Because of the dnf upgrade I still have the Fedora 23 kernel 4.5.7-202.fc23 that works, so I have compared dmesgs and found nothing useful related to drm or i915 to debug this.  Let me know what kind of information I should provide.

The laptop is a thinkpad T440 model 20B7003JBR, with this video card:

00:02.0 0300: 8086:0a16 (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)

The external monitor is plugged in via a mini displayport to HDMI adapter, and is an LG 25" ultrawide model 25UM65.

Thank you for any hints!

Comment 1 Fabio Olive Leite 2016-07-21 02:17:34 UTC
Same thing with newer kernel-4.6.4-301.fc24.x86_64.  This is what xrandr shows:

$ xrandr 
Screen 0: minimum 8 x 8, current 3286 x 1080, maximum 32767 x 32767
eDP1 connected primary 1366x768+1920+0 (normal left inverted right x axis y axis) 309mm x 174mm
   1366x768      60.00*+
   1280x720      60.00  
   1024x768      60.00  
   1024x576      60.00  
   960x540       60.00  
   800x600       60.32    56.25  
   864x486       60.00  
   640x480       59.94  
   720x405       60.00  
   680x384       60.00  
   640x360       60.00  
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
HDMI1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 677mm x 290mm
   1920x1080     60.00*   50.00    59.94    30.00    29.97  
   1920x1080i    60.00    50.00    59.94  
   1680x1050     59.88  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08  
HDMI2 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

The HDMI1 resolutions should include 2560x1080.  I'll boot back into the older kernel and paste the xrandr output from that.

Comment 2 Fabio Olive Leite 2016-07-21 02:24:17 UTC
$ uname -r
4.5.7-202.fc23.x86_64

$ xrandr 
Screen 0: minimum 8 x 8, current 3926 x 1080, maximum 32767 x 32767
eDP1 connected 1366x768+2560+0 (normal left inverted right x axis y axis) 309mm x 174mm
   1366x768      60.00*+
   1280x720      60.00  
   1024x768      60.00  
   1024x576      60.00  
   960x540       60.00  
   800x600       60.32    56.25  
   864x486       60.00  
   640x480       59.94  
   720x405       60.00  
   680x384       60.00  
   640x360       60.00  
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
HDMI1 connected primary 2560x1080+0+0 (normal left inverted right x axis y axis) 677mm x 290mm
   2560x1080     60.00*+
   1920x1080     60.00    50.00    59.94    30.00    29.97  
   1920x1080i    60.00    50.00    59.94  
   1680x1050     59.88  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.08    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08  
HDMI2 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Comment 3 Fabio Olive Leite 2016-07-21 16:16:26 UTC
Ugh, it seems bugzilla created two bugs, even though my first attempt returned an error.  Marking as duplicate.

*** This bug has been marked as a duplicate of bug 1358074 ***


Note You need to log in before you can comment on or make changes to this bug.