Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358069 - Service : ISO : Datastores not populated for RHEVM 36
Summary: Service : ISO : Datastores not populated for RHEVM 36
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.7.0
Assignee: Boriso
QA Contact: Shveta
URL:
Whiteboard: service
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 01:12 UTC by Shveta
Modified: 2016-11-14 18:47 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-14 18:47:41 UTC
Category: ---
Cloudforms Team: RHEVM


Attachments (Terms of Use)
ds not populated (deleted)
2016-07-20 01:12 UTC, Shveta
no flags Details
ISO Datastore shown in CFME (deleted)
2016-10-04 02:51 UTC, James Wong
no flags Details
Images_under_ISO_domain (deleted)
2016-11-13 11:54 UTC, Ilanit Stein
no flags Details

Description Shveta 2016-07-20 01:12:38 UTC
Created attachment 1181883 [details]
ds not populated

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Added RHEVM36 .Under Infra - PXE - ISO datastores - add new ISO datastore
2. Refresh relationships
3. datastores are not displayed.

Actual results:


Expected results:


Additional info:
Build : 5.6.0.13.20160624114606_13a9153

Comment 2 Harpreet Kataria 2016-07-20 14:29:30 UTC
Shveta,

I see the flash message on the screen indicating "Refresh Relationships successfully initiated" that does not necessarily mean that refresh is finished, did you refresh the screen after seeing the flash message, tree on the left does not refresh automatically in this case because UI has no way to know when the refresh task is finished, can you try refreshing the screen and see if you see Datastore nodes in the tree.
Let me know what you find.

Thanks,
~Harpreet

Comment 3 Shveta 2016-07-20 17:37:32 UTC
Yes Harpreet , The refresh did finish.Even after hours it didn't show anything .

Comment 4 Shveta 2016-07-20 18:28:49 UTC
This is not an issue , no active datastores under rhevm36

Comment 5 Shveta 2016-07-25 20:25:46 UTC
Re-opening the bug .
Even after adding active datastore in the environment , the datastores didn't show up in UI .
Note: The ISO datastore is type NFS . Could that be the reason ? 

RHEVM ENvt : https://cfme-qe-rhevm36.rhq.lab.eng.bos.redhat.com/ovirt-engine

CFME envt : https://10.16.5.158

Comment 6 Harpreet Kataria 2016-07-25 20:53:52 UTC
Looked into this a bit with Shveta, i do see Images available under the active Datastore in RHEV environment provided above. There are no errors in Production & EVM logs. UI seems to be working fine, for some reason iso_images table is not getting populated after the refresh. iso_images table in VMDB does not have any records.

Excerpt from EVM.log
[----] I, [2016-07-22T16:23:05.836841 #21654:a35994]  INFO -- : MIQ(IsoDatastore#synchronize_advertised_images) Synchronizing images on ISO Datastore on Management System <rhevm36>...
[----] I, [2016-07-22T16:23:05.850956 #21654:a35994]  INFO -- : MIQ(ManageIQ::Providers::Redhat::InfraManager#with_provider_connection) Connecting through ManageIQ::Providers::Redhat::InfraManager: [rhevm36]
[----] I, [2016-07-22T16:23:05.856937 #21654:a35994]  INFO -- : MIQ(ManageIQ::Providers::Redhat::InfraManager#connect) Using stored API path '/api'.
[----] I, [2016-07-22T16:23:06.609371 #21654:a35994]  INFO -- : MIQ(IsoDatastore#synchronize_advertised_images) Synchronizing images on ISO Datastore on Management System <rhevm36>...Complete

Excerpt from Production.log
[----] I, [2016-07-22T16:22:54.860043 #4569:e4acf0]  INFO -- : Completed 200 OK in 138ms (Views: 0.3ms | ActiveRecord: 0.0ms)
[----] I, [2016-07-22T16:23:00.492214 #4569:e4b290]  INFO -- : Started POST "/pxe/x_button?pressed=iso_datastore_refresh" for 127.0.0.1 at 2016-07-22 16:23:00 -0400
[----] I, [2016-07-22T16:23:00.493972 #4569:e4b290]  INFO -- : Processing by PxeController#x_button as JS
[----] I, [2016-07-22T16:23:00.494096 #4569:e4b290]  INFO -- :   Parameters: {"miq_grid_checks"=>"1", "pressed"=>"iso_datastore_refresh"}

Comment 8 Shveta 2016-08-29 22:20:12 UTC
Hi , 

So yes , we can add datastore manually but what I can see is we cannot add more than one datastore ? 

Is that how it is designed ? Means for the first time when I try to add datastore , I get the option to select any of the three datastore  available in my appliance.
But once I have added a DS , i cannot add a second DS.

Please check appliance : https://10.8.199.98

Comment 9 Oved Ourfali 2016-08-31 08:26:30 UTC
Greg - as this is not a RHEV-specific issue, can you share your knowledge here?

Comment 10 Greg Blomquist 2016-09-22 17:57:56 UTC
I don't know how ISO Datastores are supposed to work, actually.

James, can you validate this from a VMWare perspective?  It will probably involve working with some of the more experienced MIQ devs to figure this one out.  Try Rich O.

Comment 11 Shveta 2016-09-30 18:46:52 UTC
Can be checked at https://10.16.5.105

Comment 12 James Wong 2016-10-04 02:51:26 UTC
Created attachment 1207058 [details]
ISO Datastore shown in CFME

Sheva, thanks for setting up the testing environment.  I am able to access it and I can see the ISO datastore is shown as in the attached screen shot.

Greg, from my reading, this ISO Datastore feature is only applicable to RHEV (https://access.redhat.com/documentation/en/red-hat-cloudforms/4.1/provisioning-virtual-machines-and-hosts/provisioning-virtual-machines-and-hosts#adding_an_iso_datastore)

Comment 14 Shveta 2016-10-04 03:54:28 UTC
That's right James , datastore is shown but the images under it are not displayed.

Comment 15 Boriso 2016-11-03 10:13:26 UTC
Hi Shveta,
In the environment you provided, I could not currently see any provider, nor an ISO, can you please varify/make a new one, since I can't reproduce this on my local host.

Thank you.

Comment 16 Oved Ourfali 2016-11-13 09:54:40 UTC
Ilanit - can you also try to reproduce?

Comment 17 Ilanit Stein 2016-11-13 11:52:37 UTC
Tested it on CFME-5.7.0.10, and RHV-3.6.8 / RHV-4.0.4.

On both RHV-3.6.8 & RHV-4.0.4 there is an active ISO domain.

In Compute->Inra->PXE->all ISO datastores,
I added a new ISO Datastore, for the RHV-3.6,
and then for the RHV-4.0.

For both, after refresh 
(which I couldn't find anywhere in CFME UI to track it's progress), the ISO domain all images were seen. 
attached screenshot "Images_under_ISO_domain"

After adding these 2 ISO domains, the option of adding further ISO domain, under PXE, was disabled, but this makes sense, as I added all the available ISO domains.

Comment 18 Ilanit Stein 2016-11-13 11:54:50 UTC
Created attachment 1220132 [details]
Images_under_ISO_domain

Comment 19 Ilanit Stein 2016-11-13 11:56:06 UTC
The 2 ISO domains in comment 17 are from NFS type.

Comment 20 Oved Ourfali 2016-11-13 12:11:58 UTC
Shveta, based on the verification by Ilanit, may I close this issue?
Seems like it is working in 5.7.0 with both RHV 3.6.8 and 4.0.4.

Comment 21 Shveta 2016-11-14 18:38:43 UTC
Yes Please , You may close the bug. May be the issue is with the environment that I have .


Note You need to log in before you can comment on or make changes to this bug.