Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358068 - Not able to add another datastore if one is already added under ISO datastores.
Summary: Not able to add another datastore if one is already added under ISO datastores.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.7.0
Assignee: Eric Hayes
QA Contact: Shveta
URL:
Whiteboard: service
Depends On:
Blocks: 1359876
TreeView+ depends on / blocked
 
Reported: 2016-07-20 01:08 UTC by Shveta
Modified: 2017-01-04 12:58 UTC (History)
7 users (show)

Fixed In Version: 5.7.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1359876 (view as bug list)
Environment:
Last Closed: 2017-01-04 12:58:08 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)
add new button disabled (deleted)
2016-07-20 01:08 UTC, Shveta
no flags Details
providers (deleted)
2016-07-20 17:39 UTC, Shveta
no flags Details
providers available for DS (deleted)
2016-07-20 17:40 UTC, Shveta
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0012 normal SHIPPED_LIVE CFME 5.7.0 bug fixes and enhancement update 2017-01-04 17:50:36 UTC

Description Shveta 2016-07-20 01:08:49 UTC
Created attachment 1181882 [details]
add new button disabled

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Added two RHEV providers. rhevm36 and nested-rhev35
2. Under Infrastructure- PXE -ISO datastore - added ISO datastore for nested-rhevm35.
3. Add new datastore button is disabled once the datastore was added and second datastore cannot be added as shown in screenshot

Actual results:


Expected results:


Additional info:
Build : 5.6.0.13.20160624114606_13a9153

Comment 3 Shveta 2016-07-20 17:39:17 UTC
Hey Dan , 

The Hover text says " No cloud/Infra provider are available to create a datastore on" 

but there are two RHEV providers available  - nested-rhevm35(datastore added ) and rhevm36  as shown in screenshot.

If I remove nested-rhevm35 , i am able to add rhevm36 .

Comment 4 Shveta 2016-07-20 17:39:35 UTC
Created attachment 1182206 [details]
providers

Comment 5 Shveta 2016-07-20 17:40:51 UTC
Created attachment 1182207 [details]
providers available for DS

Comment 9 CFME Bot 2016-08-02 15:00:50 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/80993d4b191df2ee73813724ee1205018fb405a5

commit 80993d4b191df2ee73813724ee1205018fb405a5
Author:     Eric Hayes <eric@erichayes.net>
AuthorDate: Mon Jul 25 15:29:12 2016 -0700
Commit:     Eric Hayes <eric@erichayes.net>
CommitDate: Mon Aug 1 20:05:40 2016 -0700

    Allow more than one iso datastore per *type* of EMS.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1358068

 app/controllers/pxe_controller/iso_datastores.rb        |  6 ++++--
 app/helpers/application_helper/toolbar_builder.rb       |  9 ++++++---
 app/models/manageiq/providers/redhat/infra_manager.rb   |  8 ++++++++
 spec/controllers/pxe_controller/iso_datastores_spec.rb  | 15 +++++++++++++++
 spec/helpers/application_helper/toolbar_builder_spec.rb | 11 +++++++++++
 5 files changed, 44 insertions(+), 5 deletions(-)
 create mode 100644 spec/controllers/pxe_controller/iso_datastores_spec.rb

Comment 10 Shveta 2016-09-21 04:27:41 UTC
Fixed.
Verified in 5.7.0.0.20160906172503_12f65cb

Comment 12 errata-xmlrpc 2017-01-04 12:58:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0012.html


Note You need to log in before you can comment on or make changes to this bug.