Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358008 - please port to dnf from yum
Summary: please port to dnf from yum
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-easy-karma
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Till Maas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-19 20:03 UTC by Christian Stadelmann
Modified: 2016-08-07 14:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-07 14:46:54 UTC


Attachments (Terms of Use)

Description Christian Stadelmann 2016-07-19 20:03:26 UTC
Description of problem:
All currently supported versions of Fedora (23 and 24) are using dnf by default. f-e-k could rely on dnf only.

Version-Release number of selected component (if applicable):
fedora-easy-karma-0-0.28.20150921gitc932687a.fc24.noarch

How reproducible:
always – see source and packaging

Comment 1 Till Maas 2016-08-07 14:46:54 UTC
It works without yum if python2-dnf is installed. Using the python3 dnf module is not possible currently because not all deps for f-e-k are ported to python3.

See also bug 1329629


Note You need to log in before you can comment on or make changes to this bug.