Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358003 - 'appstream-util validate-relax' crashes with segmentation fault
Summary: 'appstream-util validate-relax' crashes with segmentation fault
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libappstream-glib
Version: rawhide
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1357838 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-19 19:43 UTC by carasin
Modified: 2016-07-21 21:37 UTC (History)
8 users (show)

Fixed In Version: glib2-2.49.4-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-21 08:51:30 UTC


Attachments (Terms of Use)

Description carasin 2016-07-19 19:43:47 UTC
Description of problem:
I am trying to repack Opera browser for Russian Fedora repository using our Koji build server. The tag is 'dist-rfr-rawhide'. The build process ends with error:
"Segmentation fault      appstream-util validate-relax --nonet"
http://koji.russianfedora.pro/koji/taskinfo?taskID=83988
http://koji.russianfedora.pro/koji/taskinfo?taskID=83980
At the moment the same builds for tags 'dist-rfr-%{22|23|24}' completed successfully.


Version-Release number of selected component (if applicable):
libappstream-glib-0.5.17-1.fc25.i686
and maybe libappstream-glib-0.5.17-1.fc25.x86_64


How reproducible:
Always. At least two builds have ended with this error.


Steps to Reproduce:
1. Build the packages according to https://github.com/RussianFedora/opera-developer or https://github.com/RussianFedora/opera-beta/
2. Use tag 'dist-fedora-rawhide'
3. See the error:"Segmentation fault      appstream-util validate-relax --nonet"


Actual results:
The build ends with error


Expected results:
The build completes successfully


Additional info:
none

Comment 1 Ben Rosser 2016-07-20 01:44:19 UTC
I've just hit the same thing attempting to rebuild pioneer in koji: https://kojipkgs.fedoraproject.org//work/tasks/4494/14954494/build.log. 

I was not able to reproduce the crash using mock with rawhide-x86_64, but I was able to with rawhide-i386.

Comment 2 Rex Dieter 2016-07-20 02:21:40 UTC
One suspect is the latest glib2 build,
http://koji.fedoraproject.org/koji/buildinfo?buildID=780747

Problems similar to this started occurring after glib2-2.49.3-1.fc25 landed, but it may also be a coincidence.

See also:
GConf2: https://bugzilla.redhat.com/show_bug.cgi?id=1357600
gtk-doc: https://bugzilla.redhat.com/show_bug.cgi?id=1357606

Comment 3 Rex Dieter 2016-07-20 02:29:11 UTC
and, 
https://fedorahosted.org/rel-eng/ticket/6446

Comment 4 Raphael Groner 2016-07-20 12:46:46 UTC
Reproducible on koschei for several packages. Raising severity.

Comment 5 Raphael Groner 2016-07-20 12:47:56 UTC
*** Bug 1357838 has been marked as a duplicate of this bug. ***

Comment 6 Kalev Lember 2016-07-21 08:51:30 UTC
Should be fixed in glib2-2.49.4-1.fc25

Comment 7 Raphael Groner 2016-07-21 10:15:24 UTC
Fix confirmed. Rebuilds of qupzilla, trojita and yarock are back to normal.

Thanks!


Note You need to log in before you can comment on or make changes to this bug.