Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357990 - Rightmost 1/4 of MacBook touchpad cannot initiate events
Summary: Rightmost 1/4 of MacBook touchpad cannot initiate events
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 24
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-19 18:24 UTC by Peter Wood
Modified: 2016-10-06 00:50 UTC (History)
11 users (show)

Fixed In Version: systemd-229-16.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-06 00:50:35 UTC


Attachments (Terms of Use)

Description Peter Wood 2016-07-19 18:24:08 UTC
Description of problem:

The rightmost 1/4 of the trackpad cannot independently initiate events, apparently. It can be used in conjunction with a tap or gesture that starts in the left 3/4 of the trackpad. For example, a two-fingered scroll with one finger on the left side and one on the right, or a two-fingered tap with one finger on the left and one on the right, or a drag motion starting on the left side and moving to the right. However, single taps on the right 1/4, or two-finger taps or gestures that occur solely in the right 1/4, do not work at all.

Version-Release number of selected component (if applicable):


How reproducible:
Install Fedora 24 on a MacBook4,1 and attempt to use the right side of the trackpad.

Steps to Reproduce:
1.
2.
3.

Actual results:

Tap/drag/scroll events are not recognized if they are initiated in the right 1/4 of the trackpad.

Expected results:

Tap/drag/scroll events should be recognized, regardless of which part of the trackpad they initiate from.


Additional info:
Info from libinput-list-devices:

Device:           appletouch
Kernel:           /dev/input/event10
Group:            8
Seat:             seat0, default
Size:             110.45x82.14mm
Capabilities:     pointer 
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    none
Disable-w-typing: enabled
Accel profiles:   none

Physical measurements of the trackpad are 100x50mm, which differs from the measurements shown in libinput-list-devices.

Comment 1 Peter Hutterer 2016-07-19 22:02:43 UTC
Run the touchpad-edge-detector tool please and attach the output here, thanks.

Comment 2 Peter Wood 2016-07-20 02:41:48 UTC
[peter@localhost ~]$ sudo touchpad-edge-detector /dev/input/event10
Touchpad applesmc on /dev/input/event10
Move one finger around the touchpad to detect the actual edges
Kernel says:	x [-256..256], y [-256..256]
Touchpad sends:	x [-2..3], y [-3..9] \^C48], y [1..5] \

Touchpad has no resolution, size unknown
Calculate resolution as:
	x axis: 512/<width in mm>
	y axis: 512/<height in mm>

Suggested udev rule:
# <Laptop model description goes here>
evdev:name:applesmc:dmi:bvnAppleInc.:bvrMB41.88Z.00C1.B00.0802091535:bd02/09/08:svnAppleInc.:pnMacBook4,1:pvr1.0:rvnAppleInc.:rnMac-F22788A9:rvrPVT:cvnAppleInc.:ct2:cvrMac-F22788A9:*
 EVDEV_ABS_00=-2:3:<x resolution>
 EVDEV_ABS_01=-3:9:<y resolution>

Comment 3 Peter Hutterer 2016-07-20 09:08:07 UTC
(In reply to Peter Wood from comment #2)
> Touchpad sends:	x [-2..3], y [-3..9] \^C48], y [1..5] \

whoah, that doesn't look right. Did you move your finger around the whole touchpad area?

Comment 4 Peter Hutterer 2016-08-08 05:06:43 UTC
ping?

Comment 5 Peter Wood 2016-08-23 13:13:14 UTC
(In reply to Peter Hutterer from comment #4)
> ping?

In response to your question, I had moved my finger around the whole touchpad, at least by my definition, which was to slide it along the entire perimeter of the touchpad, but not anywhere in the middle. 

Unfortunately, I have removed Fedora from my Macbook since I originally posted this bug, so at the moment I cannot provide any further info. If I have a chance I may try to boot Fedora from a usb stick on this machine in order to get the needed info.

I am now running Ubuntu on this machine, so if there is a way to get the same info from Ubuntu, I can do that, but I suspect it would differ since my trackpad works correctly in Ubuntu.

Comment 6 Peter Hutterer 2016-08-23 22:39:57 UTC
the same tool should be available in ubuntu, the output will be the same. And yes, moving your finger around the outside edges is sufficient but please do make sure you get all of the edges, not just the bits that are "comfortable" to reach.

Comment 7 Peter Wood 2016-08-24 02:56:25 UTC
(In reply to Peter Hutterer from comment #6)
> the same tool should be available in ubuntu, the output will be the same.
> And yes, moving your finger around the outside edges is sufficient but
> please do make sure you get all of the edges, not just the bits that are
> "comfortable" to reach.

Here's what I get in Ubuntu:

peter@petermacbook:~$ sudo touchpad-edge-detector /dev/input/event10
Touchpad appletouch on /dev/input/event10
Move one finger around the touchpad to detect the actual edges
Kernel says:	x [0..1215], y [0..575]
Touchpad sends:	x [256..1468], y [257..832] /^C[459..461] -

Touchpad has no resolution, size unknown
Calculate resolution as:
	x axis: 1215/<width in mm>
	y axis: 575/<height in mm>

Suggested udev rule:
# <Laptop model description goes here>
evdev:input:b0003v05ACp0229*
 EVDEV_ABS_00=256:1468:<x resolution>
 EVDEV_ABS_01=257:832:<y resolution>

Comment 8 Peter Hutterer 2016-08-24 04:35:36 UTC
https://github.com/systemd/systemd/pull/4030

punting over to systemd, please backport when ready


Peter: meanwhile you can look for 60-evdev.hwdb and follow the instructions at the top to add a local entry. This will fix things locally until the systemd update is ready.

Comment 9 Fedora Update System 2016-10-05 11:21:17 UTC
systemd-229-16.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-faf2598d0c

Comment 10 Fedora Update System 2016-10-06 00:50:35 UTC
systemd-229-16.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.