Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357984 - Wrong error message when using openshift ansible playbook
Summary: Wrong error message when using openshift ansible playbook
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Andrew Butcher
QA Contact: Gaoyun Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-19 18:11 UTC by Vikas Laad
Modified: 2017-12-19 03:22 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, installation would fail with an unrelated error message when openshift_hosted_registry_storage_kind=nfs was specified in the inventory but no nfs hosts were configured via openshift_hosted_registry_storage_host or the nfs host group. Playbooks now output an error message indicating that no storage hosts have been configured.
Clone Of:
Environment:
Last Closed: 2016-09-27 09:41:05 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Vikas Laad 2016-07-19 18:11:06 UTC
Description of problem:
Trying to install Openshift 3.3 cluster anible playbook run is failing with a wrong error message.

TASK [openshift_facts : Verify Ansible version is greater than or equal to 2.1.0.0] ***
Tuesday 19 July 2016  15:54:44 +0000 (0:00:01.005)       1:11:24.007 ********** 
fatal: [ec2-54-187-247-212.us-west-2.compute.amazonaws.com]: FAILED! => {"failed": true, "msg": "The conditional check 'persistent_volumes | length > 0 or persistent_volume_claims | length > 0' failed. The error was: u'{{ hostvars[groups.oo_first_master.0] | oo_persistent_volumes(groups) }}: oo_nfs_to_config'"}

Version-Release number of selected component (if applicable):
Openshift 3.3

How reproducible:
When there is no storage host detected.

Steps to Reproduce:
1. Create an inventory without any nfs host or nfs host group
2. Playbook fails with above error

Actual results:
Verify Ansible version is greater than or equal to 2.1.0.0

Expected results:
failed no storage host detected

Additional info:

Comment 2 Troy Dawson 2016-08-01 22:26:26 UTC
This has been merged and is in openshift-ansible-3.3.5-1.git.0.af6025b.el7  or newer.

Comment 3 Gaoyun Pei 2016-08-04 08:55:15 UTC
Verify this bug with openshift-ansible-3.3.6-1.git.0.5c681f6.el7.noarch.rpm

Set openshift_hosted_registry_storage_kind=nfs in the inventory, bu no openshift_hosted_registry_storage_host and [nfs] group host specified. Run the playbook, ansible would fail and prompt no storage host detected.

PLAY [Create persistent volumes] ***********************************************

TASK [setup] *******************************************************************
ok: [openshift-x.com]

TASK [openshift_facts : Detecting Operating System] ****************************
fatal: [openshift-x.com]: FAILED! => {"failed": true, "msg": "The conditional check 'persistent_volumes | length > 0 or persistent_volume_claims | length > 0' failed. The error was: {{ hostvars[groups.oo_first_master.0] | oo_persistent_volumes(groups) }}: |failed no storage host detected"}

Comment 5 errata-xmlrpc 2016-09-27 09:41:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.