Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357953 - [RFE] Power Management - warn if only a single host exists (and thus power management test cannot succeed as there's no proxy)
Summary: [RFE] Power Management - warn if only a single host exists (and thus power ma...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.6.7
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.1.0-alpha
: ---
Assignee: Eli Mesika
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-19 16:25 UTC by Marcelo Giles
Modified: 2016-08-01 21:48 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-01 21:48:03 UTC
oVirt Team: Infra


Attachments (Terms of Use)
GUI result when using TEST fencing with one host in the system (deleted)
2016-08-01 08:57 UTC, Eli Mesika
no flags Details

Description Marcelo Giles 2016-07-19 16:25:42 UTC
Description of problem:
Trying to configure Power Manager on RHEV-H returns error message in engine.log:

2016-07-19 11:49:00,086 ERROR [org.ovirt.engine.core.bll.pm.FenceProxyLocator] (ajp-/127.0.0.1:8702-3) [] Can not run fence action on host 'hosted_engine_1', no suitable proxy host was found.

Version-Release number of selected component (if applicable):
rhev-m 3.6.7

How reproducible:
Always

Steps to Reproduce:
1. Configure power management for hypervisor host
2. Test

Actual results:
Test fails with no further explanation on gui. error only available in engine.log

Expected results:
A message in the GUI, stating that there is no other host in data center that can be used to test the power management settings.

Additional info:
See: https://access.redhat.com/solutions/93623

Comment 1 Yaniv Kaul 2016-07-20 06:58:42 UTC
Do you have a single host?

Comment 2 Marcelo Giles 2016-07-20 14:06:58 UTC
Yes, that was the problem: https://access.redhat.com/solutions/93623

The request would be to have a visual alert in the GUI that tells the user that they need to add more hosts for power management to work.

Comment 3 Yaniv Kaul 2016-07-20 17:19:05 UTC
The right solution should be to allow the Engine to be another proxy, but that's a different RFE.
Rephrasing the title.

Comment 4 Eli Mesika 2016-08-01 08:56:36 UTC
As far as I see this is working as expected, see attached screen shot.

The requirement to add an alert if there is a single host in the system is not acceptable since even if you have more than one host in the system the fencing operation can fail if the proxy host has connectivity issues for example 
So, the right way IMO is the current handling where we check that at the time of the fencing operation

Adding that as an alert will force us to handle that alert in

1) host addition 
2) host removal 
3) relate to fencing flag indicating if we look for proxy in other DCs and in any event in which this flag is changed 

And, as I said above, even if you go no alert because you have other hosts that may serve as proxies, still, you can get the 'no proxy available' message if there are communication problems with the proxy

Comment 5 Eli Mesika 2016-08-01 08:57:39 UTC
Created attachment 1186301 [details]
GUI result when using TEST fencing with one host in the system

Comment 6 Marcelo Giles 2016-08-01 13:16:09 UTC
(In reply to Eli Mesika from comment #4)

Understand and agree. Thank you.


Note You need to log in before you can comment on or make changes to this bug.