Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357952 - Segfault when opening project or options dialog
Summary: Segfault when opening project or options dialog
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: qt-creator
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1359589 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-19 16:24 UTC by Andrew Mulbrook
Modified: 2016-11-06 03:19 UTC (History)
8 users (show)

Fixed In Version: qt-creator-4.1.0-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-06 03:19:22 UTC


Attachments (Terms of Use)
Backtrace of Options Dialog (deleted)
2016-07-19 16:28 UTC, Andrew Mulbrook
no flags Details

Description Andrew Mulbrook 2016-07-19 16:24:45 UTC
The Qt 5.6.1 update appears to have broken Qt-Creator. After updating, any attempt to open/create a project results in a segfault. Attempting to open the "Tools->Options" dialog also results in a segfault.

All segfaults appear to be due to null ptr deref. 

Version-Release number of selected component (if applicable):
3.5.1-4.el7.x86_64

How reproducible:
Reproduces always on current configuration.

Steps to Reproduce:
1. Launch Qt-Creator
2. Use main menu to open Options Dialog (Tools->Options)

Additional info:
Configured system is CentOS 7 w/ all updates. Nothing special.

Attempted to delete ~/.config/QtProject and friends no change.

Run with clear environment, no change.

Run with only Core plugin enabled, no change.

Comment 1 Andrew Mulbrook 2016-07-19 16:28:02 UTC
Created attachment 1181727 [details]
Backtrace of Options Dialog

I get a similar backtrace when attempting to open/create a new project.

Comment 2 Andrew Mulbrook 2016-07-19 16:29:58 UTC
Appears to be another user with a same issue on reddit. Did not see that they submitted a bug report however:

https://m.reddit.com/r/CentOS/comments/4rcv0l/qtcreator_died_with_recent_update/

Comment 3 David Summers 2016-09-07 20:49:31 UTC
This update has completely broken several people's work-flows at the company we work for.

I've found some of the RPMs to downgrade to:

https://www.reddit.com/r/CentOS/comments/4rcv0l/qtcreator_died_with_recent_update/

but not the qt5-qtbase-common-5.6.0-13.el7 RPMs (yet).

Can someone knowledgeable look at this and either give us a reference to all the required downgrade RPMs or fix the issue and provide with normal yum update?

It would be *GREATLY* appreciated, as we use this exclusively in our work.

Thanks in advance.

Comment 4 Rex Dieter 2016-09-08 12:32:38 UTC
It would appear that qt-creator has been stuck at 3.5.x in epel7 due to unsatisfied llvm dependencies of newer versions... however, according to:
https://wiki.qt.io/Building_Qt_Creator_from_Git
the Clang Code Model plugin is optional

I'll look into the possibility of syncing epel7 branch with fedora's master/ branch (containing qt-creator-4.1).  Going on the assumption here that the latest version is better-supported and works better (and fixes this bug).

Comment 5 Rex Dieter 2016-09-08 13:36:16 UTC
Here's a qt-creator-4.1.0 epel7 scratch build for folks to try out:
https://koji.fedoraproject.org/koji/taskinfo?taskID=15543005

Comment 6 Rex Dieter 2016-09-08 13:49:19 UTC
*** Bug 1359589 has been marked as a duplicate of this bug. ***

Comment 7 Rex Dieter 2016-09-08 14:18:45 UTC
Sorry, wrong link to scratch build, here's a better (successful) one:
https://koji.fedoraproject.org/koji/taskinfo?taskID=15542983

Comment 8 David Summers 2016-09-08 14:42:10 UTC
The qt-creator-4.1.0 epel 7 RPMS seem to have worked!

I can now start qt-creator.

I'll have my team check this out and report back if we find any issues / problems.

Thank you so much!

Comment 9 George Apostolopoulos 2016-10-10 13:13:23 UTC
(In reply to Rex Dieter from comment #7)
> Sorry, wrong link to scratch build, here's a better (successful) one:
> https://koji.fedoraproject.org/koji/taskinfo?taskID=15542983

Hello there,

I have the same problem with qtcreator-3.5.x on CentOS 7. 

However I do not know how to use your build of qtcreator-4 from fedora. 
Could you please indicate how one should use it.

Comment 10 Rex Dieter 2016-10-10 13:30:14 UTC
the qtcreator-4 build was for centos7, except it's been awhile and the scratch build was garbage collected.

I'll re-submit a new build now,
https://koji.fedoraproject.org/koji/taskinfo?taskID=16029173

One more bit of positive feedback, and I'll get an official build going.

Other maintainers, any objection(s) to this plan?

Comment 11 George Apostolopoulos 2016-10-18 13:23:02 UTC
Apologies for the late reply.

I tested the qt-creator-4.1.0 and it works also for me on centos7. Opened options dialog, compiled and run a project, everything ok.

Thank you very much Rex.

Comment 12 Rex Dieter 2016-10-18 13:33:40 UTC
Thanks, submitting official build now.

Comment 13 Fedora Update System 2016-10-21 16:50:22 UTC
qt-creator-4.1.0-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-209ceecddc

Comment 14 Fedora Update System 2016-11-06 03:19:22 UTC
qt-creator-4.1.0-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.