Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357917 - [abrt] WARNING: CPU: 0 PID: 120 at drivers/cpufreq/cpufreq.c:2173 cpufreq_update_policy+0x102/0x150 [NEEDINFO]
Summary: [abrt] WARNING: CPU: 0 PID: 120 at drivers/cpufreq/cpufreq.c:2173 cpufreq_upd...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:ee8c1895b19ab952d4e5627d8ad...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-19 15:01 UTC by Ervin
Modified: 2016-09-23 22:15 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-23 22:15:03 UTC
labbott: needinfo? (ervindiner)


Attachments (Terms of Use)
File: dmesg (deleted)
2016-07-19 15:02 UTC, Ervin
no flags Details

Description Ervin 2016-07-19 15:01:48 UTC
Additional info:
reporter:       libreport-2.7.1
WARNING: CPU: 0 PID: 120 at drivers/cpufreq/cpufreq.c:2173 cpufreq_update_policy+0x102/0x150
Modules linked in: ccm fuse nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ip_set nfnetlink ebtable_broute bridge stp llc ebtable_nat ip6table_raw ip6table_mangle ip6table_security ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 iptable_raw iptable_mangle iptable_security iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables arc4 ath9k ath9k_common coretemp ath9k_hw iTCO_wdt kvm iTCO_vendor_support mac80211 uvcvideo snd_hda_codec_realtek irqbypass snd_hda_codec_generic snd_hda_codec_hdmi snd_hda_intel snd_hda_codec videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 ath snd_hda_core videobuf2_core snd_hwdep videodev cfg80211 snd_seq joydev snd_seq_device
 i2c_i801 snd_pcm media snd_timer mei_me snd soundcore mei shpchp lpc_ich sony_laptop rfkill acpi_cpufreq video tpm_tis tpm nfsd auth_rpcgss nfs_acl lockd grace sunrpc amdkfd amd_iommu_v2 radeon crc32c_intel i2c_algo_bit drm_kms_helper serio_raw sdhci_pci ttm sdhci sky2 drm mmc_core fjes
CPU: 0 PID: 120 Comm: kworker/0:2 Not tainted 4.6.3-300.fc24.x86_64 #1
Hardware name: Sony Corporation VPCEA4AYC/VAIO, BIOS R1170Y8 01/28/2011
Workqueue: kacpi_notify acpi_os_execute_deferred
 0000000000000286 000000008210d52d ffff880036607b98 ffffffff813dbcff
 0000000000000000 0000000000000000 ffff880036607bd8 ffffffff810a740b
 0000087d00000000 ffff88020f50b200 00000000fffffffb ffff88020f50b310
Call Trace:
 [<ffffffff813dbcff>] dump_stack+0x63/0x84
 [<ffffffff810a740b>] __warn+0xcb/0xf0
 [<ffffffff810a753d>] warn_slowpath_null+0x1d/0x20
 [<ffffffff8166c352>] cpufreq_update_policy+0x102/0x150
 [<ffffffff8166c3a0>] ? cpufreq_update_policy+0x150/0x150
 [<ffffffff81499812>] acpi_processor_ppc_has_changed+0x5f/0x65
 [<ffffffff81496470>] acpi_processor_notify+0x56/0xe1
 [<ffffffff8147b628>] acpi_ev_notify_dispatch+0x44/0x5c
 [<ffffffff81463554>] acpi_os_execute_deferred+0x14/0x20
 [<ffffffff810c0d54>] process_one_work+0x184/0x440
 [<ffffffff810c105e>] worker_thread+0x4e/0x480
 [<ffffffff810c1010>] ? process_one_work+0x440/0x440
 [<ffffffff810c1010>] ? process_one_work+0x440/0x440
 [<ffffffff810c6f48>] kthread+0xd8/0xf0
 [<ffffffff817dd602>] ret_from_fork+0x22/0x40
 [<ffffffff810c6e70>] ? kthread_worker_fn+0x180/0x180

Comment 1 Ervin 2016-07-19 15:02:00 UTC
Created attachment 1181672 [details]
File: dmesg

Comment 2 flattargetink 2016-07-23 22:03:32 UTC
Description of problem:
Boot and login
Close lid, computer went to sleep
Open lid, message appeared.

Fedora installation is two hours old.

Version-Release number of selected component:
kernel-core-4.6.4-301.fc24

Additional info:
reporter:       libreport-2.7.2
cmdline:        BOOT_IMAGE=/boot/vmlinuz-4.6.4-301.fc24.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet LANG=en_US.UTF-8
kernel:         4.6.4-301.fc24.x86_64
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 0 PID: 4 at drivers/cpufreq/cpufreq.c:2173 cpufreq_update_policy+0x102/0x150
Modules linked in: rfcomm fuse nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ip_set nfnetlink ebtable_nat ebtable_broute bridge ip6table_security ip6table_mangle ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_raw iptable_security iptable_mangle iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_raw ebtable_filter ebtables ip6table_filter ip6_tables bnep nls_utf8 hfsplus coretemp kvm_intel snd_hda_codec_hdmi kvm joydev irqbypass snd_hda_codec_cirrus btusb btrtl btbcm btintel bluetooth snd_hda_codec_generic uvcvideo videobuf2_vmalloc applesmc videobuf2_memops videobuf2_v4l2 videobuf2_core input_polldev videodev media rfkill bcm5974 snd_hda_intel snd_hda_codec snd_hda_core snd_hwdep
 snd_seq snd_seq_device snd_pcm shpchp snd_timer snd soundcore sbs sbshc acpi_cpufreq acpi_als kfifo_buf tpm_tis tpm apple_bl industrialio nfsd auth_rpcgss nfs_acl lockd grace sunrpc hid_appleir hid_apple nouveau mxm_wmi wmi i2c_algo_bit drm_kms_helper ttm 8021q garp stp llc mrp drm tg3 firewire_ohci uas firewire_core usb_storage ptp pps_core crc_itu_t video fjes
CPU: 0 PID: 4 Comm: kworker/0:0 Not tainted 4.6.4-301.fc24.x86_64 #1
Hardware name: Apple Inc. MacBookPro7,1/Mac-F222BEC8, BIOS    MBP71.88Z.0039.B0B.1006012305 06/01/10
Workqueue: kacpi_notify acpi_os_execute_deferred
 0000000000000286 00000000163bdd82 ffff88013afebb98 ffffffff813dbcaf
 0000000000000000 0000000000000000 ffff88013afebbd8 ffffffff810a742b
 0000087d00000000 ffff88013983d200 00000000fffffffb ffff88013983d310
Call Trace:
 [<ffffffff813dbcaf>] dump_stack+0x63/0x84
 [<ffffffff810a742b>] __warn+0xcb/0xf0
 [<ffffffff810a755d>] warn_slowpath_null+0x1d/0x20
 [<ffffffff8166f642>] cpufreq_update_policy+0x102/0x150
 [<ffffffff8166f690>] ? cpufreq_update_policy+0x150/0x150
 [<ffffffff814997b1>] acpi_processor_ppc_has_changed+0x5f/0x65
 [<ffffffff8149640f>] acpi_processor_notify+0x56/0xe1
 [<ffffffff8147b5c7>] acpi_ev_notify_dispatch+0x44/0x5c
 [<ffffffff81463504>] acpi_os_execute_deferred+0x14/0x20
 [<ffffffff810c0d74>] process_one_work+0x184/0x440
 [<ffffffff810c107e>] worker_thread+0x4e/0x480
 [<ffffffff810c1030>] ? process_one_work+0x440/0x440
 [<ffffffff810c6f68>] kthread+0xd8/0xf0
 [<ffffffff817e0982>] ret_from_fork+0x22/0x40
 [<ffffffff810c6e90>] ? kthread_worker_fn+0x180/0x180

Comment 3 Alan Jenkins 2016-08-01 10:04:54 UTC
I reported this in Fedora 23 as well (https://bugzilla.redhat.com/show_bug.cgi?id=1360705).  But reposting here:


1. I think it's a regression in kernel version 4.6, caused by the cpufreq changes.  

Article on cpufreq changes: https://lwn.net/Articles/682391/

First kernel version reporting this in ABRT: 4.6.0-0.rc6.git0.1.fc25


2. This happens on resume from suspend.  On my Thinkpad X201, I can reproduce it reliably if I plug in to mains power, close the lid to trigger suspend, unplug from mains power, and then wake the system up again.

Comment 4 Alan Jenkins 2016-08-01 10:09:49 UTC
Looks like upstream are aware, with some progress for a fix to be submitted to upstream stable trees.

https://lkml.org/lkml/2016/6/27/704

Comment 5 Gonzalo San Gil 2016-08-02 13:54:12 UTC
*** Bug 1362560 has been marked as a duplicate of this bug. ***

Comment 6 Sergio Monteiro Basto 2016-08-03 17:06:22 UTC
Hello, 
Following the tip, I found  https://patchwork.kernel.org/patch/9199789/ shows State Accepted, archived and looks like that is in kernel-4.7.0 : https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/diff/drivers/cpufreq/cpufreq.c?id=v4.7&id2=v4.6 

So I built kernel-4.7.0-2 on copr 
https://copr.fedorainfracloud.org/coprs/sergiomb/builds_for_Stable_Releases/
copied src.rpm for koji [1] 

I testing ATM , after after 2 or 3 resumes , seems that is no more ooops. 

[1] 
http://koji.fedoraproject.org/koji/packageinfo?packageID=8
http://koji.fedoraproject.org/koji/buildinfo?buildID=785559

Comment 7 Josh Boyer 2016-08-04 06:59:18 UTC
(In reply to Sergio Monteiro Basto from comment #6)
> Hello, 
> Following the tip, I found  https://patchwork.kernel.org/patch/9199789/
> shows State Accepted, archived and looks like that is in kernel-4.7.0 :
> https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/diff/drivers/
> cpufreq/cpufreq.c?id=v4.7&id2=v4.6 
> 
> So I built kernel-4.7.0-2 on copr 
> https://copr.fedorainfracloud.org/coprs/sergiomb/builds_for_Stable_Releases/
> copied src.rpm for koji [1] 

You don't need to do that.  You can install 4.7.0-2 that is already built in koji.  Also, while it is great that you took the initiative and we appreciate the testing, the more people do these micro-fork kernel builds in COPR, the more we have a proliferation of kernels from random places.  That isn't sustainable in the long run.

Comment 8 Sergio Monteiro Basto 2016-08-04 07:12:22 UTC
(In reply to Josh Boyer from comment #7)
> You can install 4.7.0-2 that is already built in
> koji.  

we don't have 4.7.0-2 for F23 neither for F24 !

Comment 9 Josh Boyer 2016-08-04 07:14:44 UTC
(In reply to Sergio Monteiro Basto from comment #8)
> (In reply to Josh Boyer from comment #7)
> > You can install 4.7.0-2 that is already built in
> > koji.  
> 
> we don't have 4.7.0-2 for F23 neither for F24 !

It doesn't need to be built for f23 or f24.  The f25 version built in koji will work just fine on either release.

Comment 10 Sergio Monteiro Basto 2016-08-04 07:26:25 UTC
From devel Mailing list you also got that builds in 

https://copr.fedorainfracloud.org/coprs/jforbes/kernel-stabilization/builds/

OK, I will remove my build from copr. 

Thanks ,

Comment 11 Laura Abbott 2016-09-23 19:14:03 UTC
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 24 kernel bugs.
 
Fedora 24 has now been rebased to 4.7.4-200.fc24.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 25, and are still experiencing this issue, please change the version to Fedora 25.
 
If you experience different issues, please open a new bug report for those.

Comment 12 Alan Jenkins 2016-09-23 21:03:59 UTC
Summary: the WARNING has gone away now.  Ervin hasn't commented recently.  It'd be nice if someone with access could close the bug, thanks :).

Comment 13 Sergio Monteiro Basto 2016-09-23 22:15:03 UTC
This specific warning is fixed


Note You need to log in before you can comment on or make changes to this bug.