Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357904 - some values in Configuration tab of Cluster and Host pages are reported with wrong units
Summary: some values in Configuration tab of Cluster and Host pages are reported with ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 2
Assignee: Karnan
QA Contact: Lubos Trilety
URL:
Whiteboard:
Depends On:
Blocks: Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-07-19 14:36 UTC by Martin Bukatovic
Modified: 2016-08-23 19:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:57:30 UTC


Attachments (Terms of Use)
screenshot 1: cluster config tab (deleted)
2016-07-19 14:42 UTC, Martin Bukatovic
no flags Details
screenshot 2: host config tab (deleted)
2016-07-19 14:42 UTC, Martin Bukatovic
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Martin Bukatovic 2016-07-19 14:36:42 UTC
Description of problem
======================

Units for some values reported in Configuration tab of Cluster and Host pages
are wrong or missing.

Version-Release
===============

rhscon-ui-0.0.48-1.el7scon.noarch

Other related packages on RHSC 2.0 server machine:

rhscon-core-selinux-0.0.34-1.el7scon.noarch
rhscon-ceph-0.0.33-1.el7scon.x86_64
rhscon-core-0.0.34-1.el7scon.x86_64
ceph-installer-1.0.14-1.el7scon.noarch
ceph-ansible-1.0.5-28.el7scon.noarch

How reproducible
================

100 %

Steps to Reproduce
==================

1. Install RHSC 2.0 following the documentation.
2. Accept few nodes for the ceph cluster.
3. Create new ceph cluster named 'alpha'.
4. Check the following pages of RHSC 2.0 web ui:

 * Clusters -> alpha (item in the list) -> Configuration (tab)
 * Hosts -> some machine (item in the list) -> Configuration (tab)

Actual results
==============

On "Configuration" tab of the cluster, I see the following:

~~~
Default Journal Size 	5.0 KB
OSD down-Out interval 	300
OSD Report Timeout 	900
~~~

The problem is that "Default Journal Size" has wrong units, while the other two
values have no units at all.

On "Configuration" tab of some machine (try at least one monitor and one OSD),
I see the following:

~~~
Physical Memory 	1.8 MB
Swap Size 	2.0 MB
~~~

Again, the units reported here are wrong.

Expected results
================

On "Configuration" tab of the cluster, I see (assuming that the unit of
interval and timeout is actually specified in seconds) the following:

~~~
Default Journal Size 	5.0 GB
OSD down-Out interval 	300 s
OSD Report Timeout 	900 s
~~~

On "Configuration" tab of some machine (try at least one monitor and one OSD),
I see the following:

~~~
Physical Memory 	1.8 GB
Swap Size 	2.0 GB
~~~

Comment 1 Martin Bukatovic 2016-07-19 14:42:01 UTC
Created attachment 1181652 [details]
screenshot 1: cluster config tab

Comment 2 Martin Bukatovic 2016-07-19 14:42:27 UTC
Created attachment 1181653 [details]
screenshot 2: host config tab

Comment 4 Lubos Trilety 2016-07-28 15:26:11 UTC
Tested on:
rhscon-ceph-0.0.36-1.el7scon.x86_64
rhscon-core-selinux-0.0.36-1.el7scon.noarch
rhscon-core-0.0.36-1.el7scon.x86_64
rhscon-ui-0.0.50-1.el7scon.noarch

Comment 6 errata-xmlrpc 2016-08-23 19:57:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.