Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357897 - cron.daily entry does verbose logging
Summary: cron.daily entry does verbose logging
Keywords:
Status: CLOSED DUPLICATE of bug 1304828
Alias: None
Product: Fedora
Classification: Fedora
Component: logrotate
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kamil Dudka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-19 14:08 UTC by Dominique Brazziel
Modified: 2016-07-19 14:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-19 14:40:56 UTC


Attachments (Terms of Use)

Description Dominique Brazziel 2016-07-19 14:08:20 UTC
Description of problem:
After upgrading from Release 23 to 24, the logrotate daily cron job does verbose logging by default.  This results in many syslog messages that convey little information.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
The fix is to remove the '-l syslog' option:

diff -u logrotate~ logrotate
--- logrotate~	2016-02-16 04:12:07.000000000 -0500
+++ logrotate	2016-07-19 08:23:01.003331245 -0400
@@ -1,6 +1,6 @@
 #!/bin/sh
 
-/usr/sbin/logrotate -s /var/lib/logrotate/logrotate.status -l syslog /etc/logrotate.conf
+/usr/sbin/logrotate -s /var/lib/logrotate/logrotate.status /etc/logrotate.conf
 EXITVALUE=$?
 if [ $EXITVALUE != 0 ]; then
     /usr/bin/logger -t logrotate "ALERT exited abnormally with [$EXITVALUE]"

Comment 1 Kamil Dudka 2016-07-19 14:40:56 UTC
This is basically a duplicate of bug #1304828.  I agree this is annoying and will revert the change as you suggest.

*** This bug has been marked as a duplicate of bug 1304828 ***


Note You need to log in before you can comment on or make changes to this bug.