Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357891 - Satellite warns about satellite itself as a host without an Org in a confusing way
Summary: Satellite warns about satellite itself as a host without an Org in a confusin...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Organizations and Locations
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-19 13:44 UTC by Nenad Peric
Modified: 2018-09-04 17:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-04 17:43:39 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 21787 None None None 2017-11-27 15:28:03 UTC

Description Nenad Peric 2016-07-19 13:44:45 UTC
Description of problem:

When you open a freshly installed Satellite and go to Administer -> Organizations the WebUI throws a red box with an error:

There is _1 host with no organization assigned_ (hyperinked)


Version-Release number of selected component (if applicable):

satellite-6.2.0-20.1.el7sat.noarch

How reproducible:
Everytime

Steps to Reproduce:

Go to Administer
Click Organizations

Actual results:

The UI throws the hyperlinked error:

There is 1 host with no organization assigned
When you click on the hyperlink, it takes you to the list of hosts WITHIN the currently selected ORG, which is in this case empty, so the error is very confusing. 

Expected results:

If the error should be even displayed for the Satellite machine itself, the hyperink should lead the user to the list of hosts in Any Organization and not the currently viewed one (which is Default Org by default). 
Since the error already talks about the host WITHOUT the org, it should not list the hosts WITHIN the Org (since logically it would not be there).

Comment 2 Ondřej Pražák 2017-11-27 15:28:01 UTC
Created redmine issue http://projects.theforeman.org/issues/21787 from this bug

Comment 3 Bryan Kearney 2018-09-04 17:43:39 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.