Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357889 - certbot fails on epel7
Summary: certbot fails on epel7
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: certbot
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: James Hogarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-19 13:39 UTC by Pierre-YvesChibon
Modified: 2016-07-19 16:24 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-19 13:57:23 UTC


Attachments (Terms of Use)

Description Pierre-YvesChibon 2016-07-19 13:39:28 UTC
Description of problem:
I tried running cerbot on epel7, it fails just after the ncurse window asks for the email address.

Version-Release number of selected component (if applicable):
python2-certbot-0.8.1-2.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. certbot certonly --standalone -d <domain>
2. provide the email in the ncurse window
3. crashs

Actual results:
2016-07-19 13:36:29,368:DEBUG:certbot.main:Root logging level set at 30
2016-07-19 13:36:29,369:INFO:certbot.main:Saving debug log to /var/log/letsencrypt/letsencrypt.log
2016-07-19 13:36:29,369:DEBUG:certbot.main:certbot version: 0.8.1
2016-07-19 13:36:29,369:DEBUG:certbot.main:Arguments: ['--standalone', '-d', 'hubs-dev.fedorainfracloud.org']
2016-07-19 13:36:29,369:DEBUG:certbot.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#webroot,PluginEntryPoint#null,PluginEntryPoint#manual,PluginEntryPoint#standalone)
2016-07-19 13:36:29,377:DEBUG:certbot.plugins.selection:Requested authenticator standalone and installer None
2016-07-19 13:36:29,486:DEBUG:certbot.plugins.selection:Single candidate plugin: * standalone
Description: Automatically use a temporary webserver
Interfaces: IAuthenticator, IPlugin
Entry point: standalone = certbot.plugins.standalone:Authenticator
Initialized: <certbot.plugins.standalone.Authenticator object at 0x1b2d450>
Prep: True
2016-07-19 13:36:29,486:DEBUG:certbot.plugins.selection:Selected authenticator <certbot.plugins.standalone.Authenticator object at 0x1b2d450> and installer None
2016-07-19 13:36:36,802:DEBUG:certbot.main:Exiting abnormally:
Traceback (most recent call last):
  File "/usr/bin/certbot", line 9, in <module>
    load_entry_point('certbot==0.8.1', 'console_scripts', 'certbot')()
  File "/usr/lib/python2.7/site-packages/certbot/main.py", line 744, in main
    return config.func(config, plugins)
  File "/usr/lib/python2.7/site-packages/certbot/main.py", line 550, in obtain_cert
    le_client = _init_le_client(config, auth, installer)
  File "/usr/lib/python2.7/site-packages/certbot/main.py", line 360, in _init_le_client
    acc, acme = _determine_account(config)
  File "/usr/lib/python2.7/site-packages/certbot/main.py", line 345, in _determine_account
    config, account_storage, tos_cb=_tos_cb)
  File "/usr/lib/python2.7/site-packages/certbot/client.py", line 117, in register
    backend=default_backend())))
  File "/usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/__init__.py", line 40, in default_backend
    _default_backend = MultiBackend(_available_backends())
  File "/usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/__init__.py", line 27, in _available_backends
    "cryptography.backends"
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2208, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/__init__.py", line 7, in <module>
    from cryptography.hazmat.backends.openssl.backend import backend
  File "/usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/backend.py", line 37, in <module>
    from cryptography.hazmat.backends.openssl.x509 import _Certificate
  File "/usr/lib64/python2.7/site-packages/cryptography/hazmat/backends/openssl/x509.py", line 18, in <module>
    from cryptography import utils, x509
  File "/usr/lib64/python2.7/site-packages/cryptography/x509/__init__.py", line 8, in <module>
    from cryptography.x509.base import (
  File "/usr/lib64/python2.7/site-packages/cryptography/x509/base.py", line 15, in <module>
    from cryptography.x509.extensions import Extension, ExtensionType
  File "/usr/lib64/python2.7/site-packages/cryptography/x509/extensions.py", line 20, in <module>
    from cryptography.x509.general_name import GeneralName, IPAddress, OtherName
  File "/usr/lib64/python2.7/site-packages/cryptography/x509/general_name.py", line 18, in <module>
    from cryptography.x509.name import Name
  File "/usr/lib64/python2.7/site-packages/cryptography/x509/name.py", line 10, in <module>
    from cryptography.x509.oid import NameOID, ObjectIdentifier
  File "/usr/lib64/python2.7/site-packages/cryptography/x509/oid.py", line 101, in <module>
    utils.DeprecatedIn12
AttributeError: 'module' object has no attribute 'DeprecatedIn12'


Expected results:
certs :)

Comment 1 James Hogarth 2016-07-19 13:57:23 UTC
Did a quick test and I cannot reproduce in a fresh C7 install with stable or testing certbot packages

Probably a bad pip clash? https://github.com/certbot/certbot/issues/3278

Comment 2 Pierre-YvesChibon 2016-07-19 16:24:12 UTC
It was likely a messed-up with pip.

I yum remove python-cryptography, since there were some files left I rm'ed them and reinstall certbot (which brought python-cryptography w/ it) after that it worked fine.

Thanks and sorry for the troubles!


Note You need to log in before you can comment on or make changes to this bug.