Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357887 - bootstrap does not enable rhel-*-satellite-tools-*-rpms repository, failing to install katello-agent/puppet
Summary: bootstrap does not enable rhel-*-satellite-tools-*-rpms repository, failing t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Bootstrap
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Rich Jerrido
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-19 13:29 UTC by Evgeni Golov
Modified: 2019-04-01 20:27 UTC (History)
5 users (show)

Fixed In Version: katello-client-bootstrap-1.1.0-2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:18:32 UTC


Attachments (Terms of Use)

Description Evgeni Golov 2016-07-19 13:29:04 UTC
Description of problem:
bootstrap.py will try to install katello-agent and puppet, these are hower shipped in the additional rhel-*-satellite-tools-*-rpms repository, which is not enabled by default

Version-Release number of selected component (if applicable):
6.2.0 beta 2

How reproducible:
100%

Steps to Reproduce:
1. try to run bootstrap.py

Actual results:
katello-agent and puppet RPMs cannot be found

Expected results:
machine is properly attached to satellite, katello-agent and puppet are installed


Additional info:

Comment 3 Roman Plevka 2016-07-22 13:00:12 UTC
VERIFIED
on satellite-6.2.0-21.1.el6sat.noarch

the function has been added to the script and is being executed correctly.

Comment 4 Bryan Kearney 2016-07-27 11:18:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.