Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357878 - virt-who checkin should use default org view unless the hypervisor is registered
Summary: virt-who checkin should use default org view unless the hypervisor is registered
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Candlepin
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: 6.2
Assignee: Justin Sherrill
QA Contact: Peter Ondrejka
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1389102
TreeView+ depends on / blocked
 
Reported: 2016-07-19 12:58 UTC by Justin Sherrill
Modified: 2018-12-06 20:45 UTC (History)
5 users (show)

Fixed In Version: tfm-rubygem-katello-3.0.0.82-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1389102 (view as bug list)
Environment:
Last Closed: 2016-11-10 08:13:29 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2699 normal SHIPPED_LIVE Satellite 6.2.4 Async Bug Release 2016-11-10 13:12:22 UTC
Foreman Issue Tracker 15725 None None None 2016-07-19 13:05:28 UTC

Description Justin Sherrill 2016-07-19 12:58:04 UTC
Right now virt-who checkin's still register the host to a specific content view and lifecycle environment, but the create host has no content facet.  This is incorrect and should just use the default org view and library

Comment 1 Justin Sherrill 2016-07-19 12:58:06 UTC
Created from redmine issue http://projects.theforeman.org/issues/15725

Comment 2 Justin Sherrill 2016-07-19 13:02:11 UTC
Note that in the UI, you won't see it associated with any lifecycle env or content view (this is expected).  But if you look in  'hammer content-host list'  it shows up as belonging to one other than the Librar/default org view.  This is incorrect.   If you try to change it you'll get an error as its not meant to be changed.

Comment 4 Bryan Kearney 2016-08-08 14:17:00 UTC
Upstream bug component is Candlepin

Comment 5 Bryan Kearney 2016-08-17 16:16:41 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/15725 has been closed

Comment 9 Peter Ondrejka 2016-11-09 14:27:06 UTC
Verified in 6.2.4 3.0, confirmed through UI and CLI that new virtual hosts check in to Library/default-org-view in the above scenario.

Comment 11 errata-xmlrpc 2016-11-10 08:13:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:2699


Note You need to log in before you can comment on or make changes to this bug.