Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357854 - Glib makes MATE Caja filemanager segfault
Summary: Glib makes MATE Caja filemanager segfault
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: glib2
Version: 24
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-19 12:10 UTC by Steffen Mikkelsen
Modified: 2016-07-30 18:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-30 18:11:26 UTC


Attachments (Terms of Use)
stacktrace from crash (deleted)
2016-07-19 12:10 UTC, Steffen Mikkelsen
no flags Details

Description Steffen Mikkelsen 2016-07-19 12:10:26 UTC
Created attachment 1181611 [details]
stacktrace from crash

Description of problem:
Sometimes when opening Caja filemanager, it will crash with a SEGFAULT. I filed a bug with the MATE developers that say it is a bug in glib.

https://github.com/mate-desktop/caja/issues/594

Version-Release number of selected component (if applicable):


How reproducible:
Happens maybe 1/50 times Caja is started


Steps to Reproduce:
*Try to open from MATE Panel Menu: Places - Desktop
*Alternatively try to open from transmission-gtk by right clicking torrent "Open Folder"



Additional info:

Attached gdb stacktrace

Output from dmesg when it crashes:
[17099.098958] caja[14625]: segfault at 100000009 ip 00007fd08f7303c8 sp 00007fffe0370930 error 4 in libc-2.23.so[7fd08f6b4000+1b9000]
[17236.074419] caja[15183]: segfault at 100000009 ip 00007f2b4303b3c8 sp 00007ffcc3355d70 error 4 in libc-2.23.so[7f2b42fbf000+1b9000]
[17493.527674] caja[16584]: segfault at 100000009 ip 00007f0b5bf6a3c8 sp 00007fff2eebc7e0 error 4 in libc-2.23.so[7f0b5beee000+1b9000]
[17832.061129] caja[18463]: segfault at 100000009 ip 00007fbb905883c8 sp 00007ffdb33155f0 error 4 in libc-2.23.so[7fbb9050c000+1b9000]
[17969.252398] caja[18822]: segfault at 100000009 ip 00007fe6aa8643c8 sp 00007ffe4c565900 error 4 in libc-2.23.so[7fe6aa7e8000+1b9000]

Comment 1 Paul Howarth 2016-07-19 12:16:26 UTC
This is glib2, not glib.

Comment 2 Steffen Mikkelsen 2016-07-30 18:11:26 UTC
Problem seems to be caused by NVIDIA Driver. Switching to Nouveau driver fixes the problem.


Note You need to log in before you can comment on or make changes to this bug.