Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357839 - [RFE] Installer should check the status of free space in root (/) and throw a warning in case it is lacking
Summary: [RFE] Installer should check the status of free space in root (/) and throw a...
Keywords:
Status: CLOSED DUPLICATE of bug 1263161
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Chris Roberts
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-19 11:02 UTC by Nenad Peric
Modified: 2016-08-23 16:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 16:53:50 UTC


Attachments (Terms of Use)

Description Nenad Peric 2016-07-19 11:02:18 UTC
Description of problem:

If there is not enough space to sync things and work with Satellite after it has been installed, (namely / fs) a lot of funny things can happen which are not immediately obvious. 
Unknown errors (Something went wrong) and mongo connection issues can pop up which in turn would cause a lot of issues with Satellite itself. 

Version-Release number of selected component (if applicable):


How reproducible:

Every time you run out of space in /

Steps to Reproduce:

Get the / FS to 100%, stuff just starts breaking but the errors Sat is giving out do not help in determining the real issue. 


Expected results:

Perhaps a feature should be added to the installer which warns the user if the remaining space in / fs is too low for syncing a few ISOs afterwards (say less than 20GB remaining?). 
It should not be a critical error, since the user could potentially allocate more space to / after the installation is complete. 
The default RHEL 7 installation allocates inadequate amount of space to the / fs for Satellite usage (around 50GB in my default setup).

Comment 2 Stephen Benjamin 2016-08-23 16:53:50 UTC

*** This bug has been marked as a duplicate of bug 1263161 ***


Note You need to log in before you can comment on or make changes to this bug.