Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357822 - systemd-udev needs a patch backported due to string error, causes shenanigans with rules
Summary: systemd-udev needs a patch backported due to string error, causes shenanigans...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 24
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1342533 1352685 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-19 10:10 UTC by steubens
Modified: 2016-07-24 03:32 UTC (History)
11 users (show)

Fixed In Version: systemd-229-9.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-23 18:48:46 UTC


Attachments (Terms of Use)

Description steubens 2016-07-19 10:10:08 UTC
Description of problem:
ATTR{idProduct}=="0015" was ending up as "2015" for an inexplicable reason

did my own debugging and on the third day someone pointed out a patch to fix it

How reproducible:
every time, description is at gh url for change

Steps to Reproduce:
see gh url

Actual results:
rules get mixed up and never match

Expected results:
rules work

Additional info:
github link for the patch
https://github.com/systemd/systemd/commit/c45606eb95a7171b0dc801e91d35034957ad5e9e

Comment 1 Michal Schmidt 2016-07-19 11:31:27 UTC
*** Bug 1342533 has been marked as a duplicate of this bug. ***

Comment 2 Michal Schmidt 2016-07-19 14:07:54 UTC
*** Bug 1352685 has been marked as a duplicate of this bug. ***

Comment 3 Gerhard Wiesinger 2016-07-19 15:57:47 UTC
Can you please release a new systemd version for Fedora.

Comment 4 Fedora Update System 2016-07-21 06:47:01 UTC
systemd-229-9.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-47bda25e7a

Comment 5 Fedora Update System 2016-07-21 18:52:51 UTC
systemd-229-9.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-47bda25e7a

Comment 6 Gerhard Wiesinger 2016-07-22 07:40:44 UTC
Can confirm it works again as in FC23: See: https://bugzilla.redhat.com/show_bug.cgi?id=1352685

Comment 7 Fedora Update System 2016-07-23 18:48:00 UTC
systemd-229-9.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.