Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357821 - Make install fails second time without uninstall
Summary: Make install fails second time without uninstall
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: eventsapi
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1351589
TreeView+ depends on / blocked
 
Reported: 2016-07-19 10:08 UTC by Aravinda VK
Modified: 2017-03-27 18:18 UTC (History)
0 users

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-27 18:18:00 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2016-07-19 10:08:43 UTC
Description of problem:
Make install fails with File already exists error for $SBIN/gluster-eventsapi if run second time.

Comment 1 Aravinda VK 2016-07-19 10:17:17 UTC
Patch sent to Upstream http://review.gluster.org/14954

Comment 2 Vijay Bellur 2016-07-21 10:24:37 UTC
COMMIT: http://review.gluster.org/14954 committed in master by Aravinda VK (avishwan@redhat.com) 
------
commit ec72746af0ee94c7b9b96fa7685490b02583f393
Author: Aravinda VK <avishwan@redhat.com>
Date:   Tue Jul 19 15:41:54 2016 +0530

    eventsapi: Fix make install issue second time
    
    If Symlink file $SBIN/gluster-eventsapi is not deleted,
    make install was failing when run second time(Without uninstall)
    
    With this patch, Symlink deleted before installing new symlink.
    
    BUG: 1357821
    Change-Id: I65e636f7b48ba9e81177f56c720ffc27e1f95fb3
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/14954
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>

Comment 3 Shyamsundar 2017-03-27 18:18:00 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.