Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357820 - Need add profiling flags to /etc/etcd/etcd.conf in etcd-2.3.7
Summary: Need add profiling flags to /etc/etcd/etcd.conf in etcd-2.3.7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: etcd
Version: 7.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Jan Chaloupka
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-19 09:56 UTC by Joy Pu
Modified: 2016-09-15 08:30 UTC (History)
0 users

Fixed In Version: etcd-2.3.7-4.el7
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2016-09-15 08:30:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1828 normal SHIPPED_LIVE etcd bug fix update 2016-09-15 11:56:11 UTC

Description Joy Pu 2016-07-19 09:56:04 UTC
Description of problem:

New added flags for profiling is not added to the etcd.conf file.
Here is the flags from etcd --help:

profiling flags:
	--enable-pprof 'false'
		Enable runtime profiling data via HTTP server. Address is at client URL + "/debug/pprof"


Version-Release number of selected component (if applicable):
etcd-2.3.7

How reproducible:
100%

Steps to Reproduce:
1. Get etcd --help
$ etcd --help
2. Compare the flags with the flags we get from etcd.conf

Actual results:
one new added flag missing

Expected results:
The flag should be added

Additional info:

Comment 2 Jan Chaloupka 2016-07-19 10:56:58 UTC
This does not affect AH 7.2.6. The flags that are commented out in the etcd.config file does not take any effect. At the same time, they are set in the file so an etcd operator is aware of them and does not have to read the etcd documentation. For additional information about available options/flags and their meaning, it is always necessary to read the documentation and update the etcd.conf accordingly.

Thus, I will update the etcd.conf only without rebuilding.

Comment 5 Joy Pu 2016-08-26 07:38:32 UTC
Checked in the etcd-2.3.7-4.el7, the flag is added:

#[profiling]
#ETCD_ENABLE_PPROF="false"

So set this to verified.

Comment 7 errata-xmlrpc 2016-09-15 08:30:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1828.html


Note You need to log in before you can comment on or make changes to this bug.