Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357753 - JSON output for all Events CLI commands
Summary: JSON output for all Events CLI commands
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: eventsapi
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1395603 1400845
TreeView+ depends on / blocked
 
Reported: 2016-07-19 05:43 UTC by Aravinda VK
Modified: 2017-03-06 17:21 UTC (History)
0 users

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1395603 1400845 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:21:32 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2016-07-19 05:43:38 UTC
Description of problem:
To consume the APIs programatically, provide JSON or XML output for gluster-eventsapi commands.

Example, 

gluster-eventsapi start --json
gluster-eventsapi status --json

Comment 1 Worker Ant 2016-11-17 11:10:02 UTC
REVIEW: http://review.gluster.org/15867 (eventsapi: JSON output and different error codes) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 2 Worker Ant 2016-11-29 11:58:05 UTC
REVIEW: http://review.gluster.org/15867 (eventsapi: JSON output and different error codes) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 3 Worker Ant 2016-12-02 08:20:42 UTC
COMMIT: http://review.gluster.org/15867 committed in master by Aravinda VK (avishwan@redhat.com) 
------
commit da71bdcf82a8dc71a1170ad3f190702fa49d2838
Author: Aravinda VK <avishwan@redhat.com>
Date:   Thu Nov 17 15:42:24 2016 +0530

    eventsapi: JSON output and different error codes
    
    JSON outputs are added to all commands, use `--json` to
    get JSON output.
    
    Following error codes are added to differenciate between errors.
    Any other Unknown errors will have return code 1
    
    ERROR_SAME_CONFIG             = 2
    ERROR_ALL_NODES_STATUS_NOT_OK = 3
    ERROR_PARTIAL_SUCCESS         = 4
    ERROR_WEBHOOK_ALREADY_EXISTS  = 5
    ERROR_WEBHOOK_NOT_EXISTS      = 6
    ERROR_INVALID_CONFIG          = 7
    ERROR_WEBHOOK_SYNC_FAILED     = 8
    ERROR_CONFIG_SYNC_FAILED      = 9
    
    Also hidden `node-` commands in the help message.
    
    BUG: 1357753
    Change-Id: I962b5435c8a448b4573059da0eae42f3f93cc97e
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/15867
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Prashanth Pai <ppai@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 4 Shyamsundar 2017-03-06 17:21:32 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.