Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357686 - Heketi and GlusterFS deployment strategy needs to use Recreate not Rolling
Summary: Heketi and GlusterFS deployment strategy needs to use Recreate not Rolling
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi
Version: rhgs-3.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: CNS 3.4
Assignee: Mohamed Ashiq
QA Contact: Apeksha
URL:
Whiteboard:
Depends On:
Blocks: 1385246
TreeView+ depends on / blocked
 
Reported: 2016-07-18 21:32 UTC by Luis Pabón
Modified: 2017-01-18 21:56 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-18 21:56:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:0148 normal SHIPPED_LIVE heketi bug fix and enhancement update 2017-01-19 02:53:24 UTC
Github heketi heketi issues 433 None None None 2016-07-19 00:27:33 UTC

Description Luis Pabón 2016-07-18 21:32:15 UTC
Description of problem:
If a new upgraded container is available, the administrator can type:

$ oc deploy heketi --latest

To deploy the latest Heketi container.  The problem is that using a "Rolling"
strategy will not deploy the new Heketi, since the old one still has access the to the database.  Need to change the strategy to "Recreate" so that the previous container is shut down first before deploying the new one.

Comment 2 Luis Pabón 2016-07-19 00:34:07 UTC
This is a blocker because we cannot upgrade Heketi or GlusterFS without the correct setting.

This affects both the Heketi and GlusterFS templates.

Comment 8 Neha 2016-07-24 09:31:47 UTC
I believe this is not expected behaviour. @Humble , could you please give a look.

Comment 9 Humble Chirammal 2016-07-25 12:48:49 UTC
(In reply to Neha from comment #8)
> I believe this is not expected behaviour. @Humble , could you please give a
> look.

@Neha, the 'recreate' strategy should stop the pod and deploy the new one without issues. We have analysed the root cause and the solution for this issue which will be updated soon in this bugzilla.

Comment 26 Apeksha 2016-11-25 11:55:31 UTC
Verified on build - heketi-client-3.0.0-2.el7rhgs.x86_64

Comment 28 errata-xmlrpc 2017-01-18 21:56:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2017-0148.html


Note You need to log in before you can comment on or make changes to this bug.