Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357640 - Create stack failed from Horizon UI due to No content found in the "files" section
Summary: Create stack failed from Horizon UI due to No content found in the "files" se...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 8.0 (Liberty)
Assignee: Radomir Dopieralski
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-18 18:12 UTC by Andreas Karis
Modified: 2016-09-07 15:44 UTC (History)
6 users (show)

Fixed In Version: python-django-horizon-8.0.1-6.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-07 15:44:31 UTC


Attachments (Terms of Use)
no content found (deleted)
2016-07-18 18:12 UTC, Andreas Karis
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1822 normal SHIPPED_LIVE python-django-horizon bug fix advisory 2016-09-07 19:42:40 UTC

Description Andreas Karis 2016-07-18 18:12:18 UTC
Created attachment 1181228 [details]
no content found

Description of problem:
Horizon throws the following error when using the get_files function in combination with a URL: 
error property error no content found in the files section for get_files

Version-Release number of selected component (if applicable):
python-django-horizon-8.0.1-2.el7ost.noarch

How reproducible:
with the following stack

~~~
heat_template_version: 2015-10-15

resources:
  re:
    properties:
      config_drive: true
      flavor: m1.tiny
#      image: cirros
      image: 7449ff55-f0d4-4732-a05c-6bb2fd5e0561
      name: testtest
      networks:
      - network: private
      personality: {
        /root/baseline_config.template: {get_file: 'http://10.0.0.250/vmx_baseline.conf'}}
    type: OS::Nova::Server
~~~

The stack works fine from the CLI 
~~~
heat stack-create --template-file nova.yaml server
~~~

Steps to Reproduce:
1. PROJECT -> ORCHESTRATION -> STACKS -> LAUNCH STACK 
2. provide the above stack definition
3. check attached screenshot for error message

Actual results:
Create stack failed from Horizon UI due to No content found in the "files" section 

Expected results:
This sould work just fine

Additional info:
Upstream bug report and fix:
https://bugs.launchpad.net/horizon/+bug/1512564

Comment 3 Ido Ovadia 2016-09-05 09:40:14 UTC
Verified
========
python-django-horizon-8.0.1-6.el7ost.noarch

Comment 5 errata-xmlrpc 2016-09-07 15:44:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1822.html


Note You need to log in before you can comment on or make changes to this bug.