Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357635 - A problem with instructions on creating a swap file
Summary: A problem with instructions on creating a swap file
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Storage_Admin_Guide
Version: 6.8
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Milan Navratil
QA Contact: ecs-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-18 17:39 UTC by Milan Navratil
Modified: 2016-07-20 15:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-20 15:41:41 UTC


Attachments (Terms of Use)

Description Milan Navratil 2016-07-18 17:39:33 UTC
Document URL: 

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Storage_Administration_Guide/ch-swapspace.html

Section Number and Name: 

15.1.3. Creating a Swap File

Describe the issue: 

Jaewoo Jeon wrote an email to Milan Navratil describing the issue as follows:

I ran across this article while looking for a quick guide to set up swap space on RHEL 6 installation. The section 15.1.3. worked well for me. However I was bit confused when I encountered following direction:

~~~~~
To enable it at boot time, edit /etc/fstab to include the following entry:

/swapfile swap swap defaults 0 0

The next time the system boots, it enables the new swap file.
~~~~~

Other entries in the /etc/fstab and other guides on the web (albeit different distribution and unofficial documents) suggest that the order should instead be:

~~~~~
swap /swapfile swap defaults 0 0
~~~~~

But then the document is official, so I may be wrong. Is this an error in the documentation or is this just different in redhat?

Suggestions for improvement: 

Verify with a subject matter expert and either provide an explanation to the reporter, or make the change as suggested.

Comment 3 David Shea 2016-07-18 18:02:19 UTC
The documentation is correct. The first column is the device to be mounted, in this case the swap file. The second column is the mount point. Swap has no mount point, so "swap" is used as a placeholder. The important part is that the swap file needs to be in the first column. Placing the swap file in the second column will not work.

Comment 6 Milan Navratil 2016-07-20 15:41:41 UTC
Thank you for the information, David.

I'm closing this BZ with a resolution "not a bug" and let Jaewoo Jeon know by email.

Thanks again.


Note You need to log in before you can comment on or make changes to this bug.