Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357623 - Syncpipe write failed in 0.99.2-1
Summary: Syncpipe write failed in 0.99.2-1
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: clamav
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Jim Radford
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-18 16:34 UTC by infinitnetsolutions
Modified: 2016-10-13 02:27 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-13 02:27:58 UTC


Attachments (Terms of Use)

Description infinitnetsolutions 2016-07-18 16:34:43 UTC
clamd keeps shutting itself down after it has been running for about 2 seconds. Debug log below, but it didn't provide more information than "Syncpipe write failed" which I would guess is the responsible part of this. Everything was working prior to the latest RPM update on July 2nd or so (version 0.99.2-1). I'm using CentOS 7.

[...]
Jul 18 18:21:56 helloworld clamd[3336]: Archive support enabled.
Jul 18 18:21:56 helloworld clamd[3336]: Algorithmic detection enabled.
Jul 18 18:21:56 helloworld clamd[3336]: Portable Executable support enabled.
Jul 18 18:21:56 helloworld clamd[3336]: ELF support enabled.
Jul 18 18:21:56 helloworld clamd[3336]: Detection of broken executables enabled.
Jul 18 18:21:56 helloworld clamd[3336]: Mail files support enabled.
Jul 18 18:21:56 helloworld clamd[3336]: OLE2 support enabled.
Jul 18 18:21:56 helloworld clamd[3336]: PDF support enabled.
Jul 18 18:21:56 helloworld clamd[3336]: SWF support enabled.
Jul 18 18:21:56 helloworld clamd[3336]: HTML support enabled.
Jul 18 18:21:56 helloworld clamd[3336]: XMLDOCS support enabled.
Jul 18 18:21:56 helloworld clamd[3336]: HWP3 support enabled.
Jul 18 18:21:56 helloworld clamd[3336]: Self checking every 600 seconds.
Jul 18 18:21:56 helloworld clamd[3336]: Listening daemon: PID: 3336
Jul 18 18:21:56 helloworld clamd[3336]: MaxQueue set to: 100
Jul 18 18:21:56 helloworld clamd[3336]: fds_poll_recv: timeout after 600 seconds
Jul 18 18:21:57 helloworld clamd[3336]: Shutdown closed fd 7
Jul 18 18:21:57 helloworld clamd[3336]: Waiting for all threads to finish
Jul 18 18:21:57 helloworld clamd[3336]: Received POLLIN|POLLHUP on fd 9
Jul 18 18:21:57 helloworld clamd[3336]: Shutdown: closed fd 5
Jul 18 18:21:57 helloworld clamd[3336]: Shutdown: closed fd 6
Jul 18 18:21:57 helloworld clamd[3336]: Shutdown: closed fd 9
Jul 18 18:21:57 helloworld clamd[3336]: Syncpipe write failed
Jul 18 18:21:58 helloworld clamd[3336]: Shutting down the main sockets.
Jul 18 18:21:58 helloworld clamd[3336]: Pid file removed.
Jul 18 18:21:58 helloworld clamd[3336]: --- Stopped at Mon Jul 18 18:21:58 2016
Jul 18 18:21:58 helloworld clamd[3336]: Closing the main sockets.
Jul 18 18:21:58 helloworld clamd[3336]: Socket file removed.

Comment 1 jr_c_2001fr 2016-08-09 12:30:02 UTC
Hello.
I've exactly the same logs and the same things.
Starting the service, it stop after 2 seconds running without any explanation about the reasons making it to stop.
I run clamav-server-0.99.2-1.el7.x86_64 on CentOS 7 x64  3.10.0-327.22.2.el7.x86_64

Comment 2 jr_c_2001fr 2016-09-19 04:14:21 UTC
(In reply to jr_c_2001fr from comment #1)
> Hello.
> I've exactly the same logs and the same things.
> Starting the service, it stop after 2 seconds running without any
> explanation about the reasons making it to stop.
> I run clamav-server-0.99.2-1.el7.x86_64 on CentOS 7 x64 
> 3.10.0-327.22.2.el7.x86_64

In fact, I've found a workaround.
In my /usr/lib/systemd/system/clamd@.service file I added --foreground=yes option on ExecStart command Line. With this option, after systemctl deamon-relaod, Clamd continues running.
The problem is when I run systemctl start clamd@amavisd.service, the command doesn't wait for the daemon really started before ending.

Comment 3 Orion Poplawski 2016-10-13 02:27:58 UTC
The supplied clamd@.service has --foreground=yes in it.  The option name changed with 0.99.2.  If you have a modified clamd@*.service file it will need to be updated.


Note You need to log in before you can comment on or make changes to this bug.