Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357588 - [RFE] Add cloud_init capability to Foreman component of Satellite
Summary: [RFE] Add cloud_init capability to Foreman component of Satellite
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning
Version: 6.1.9
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-18 15:03 UTC by Rick Dixon
Modified: 2016-07-29 13:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-29 13:38:39 UTC


Attachments (Terms of Use)

Description Rick Dixon 2016-07-18 15:03:44 UTC
Description of problem:

When provisioning in an environment utilizing external DHCP, no IP address should be necessary to enter into the IP Address field of the New Host creation. When this field is left blank, however, the kickstart finishing script cannot be executed on the kickstarted host because Satellite does not "know" the IP address of the host to make an SSH connection for the finishing script.

This could be worked with the implementation of cloud_init, which would be virtual media spun up on the new host and would automatically apply final configurations as defined in the accompanying yaml file. The end result would be the same as if the finish script has run, but no SSH session from the Satellite would be required.

Currently, it appears that cloud_init capability was introduced in Foreman 1.9 and can be configured from a "User Data" link under Compute Resources. 


How reproducible:

Always.


Steps to Reproduce:
1. Spin up a new host and do not define an IP address (as this would be assigned via external an DHCP service)

2. Associate a kickstart finishing script to be executed upon host creation


Actual results:

The finishing script will never execute as the Satellite requires a predefined IP address to SSH into the new host and execute the finish script


Expected results:

Ideally, the finish script would execute without requiring a predefined IP address.

Comment 1 Ivan Necas 2016-07-29 13:38:39 UTC
The Satellite 6.2 is based on Foreman 1.11, that has the user_data capability


Note You need to log in before you can comment on or make changes to this bug.