Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357515 - [RFE] Allow reporting relationship between OpenShift pods and the image they run
Summary: [RFE] Allow reporting relationship between OpenShift pods and the image they run
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.7.4
Assignee: Gregg Tanzillo
QA Contact: Jaroslav Henner
URL:
Whiteboard:
Depends On:
Blocks: 1362627
TreeView+ depends on / blocked
 
Reported: 2016-07-18 12:11 UTC by Jon Jozwiak
Modified: 2017-08-28 14:54 UTC (History)
10 users (show)

Fixed In Version: 5.7.0.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1362627 (view as bug list)
Environment:
Last Closed: 2017-08-28 14:54:30 UTC
Category: ---
Cloudforms Team: CFME Core


Attachments (Terms of Use)

Description Jon Jozwiak 2016-07-18 12:11:16 UTC
Description of problem:

There are 2 reports desired for a use case around accounting for software license/subscription usage. 

1) Show a count of all images in use per OpenShift project and their count of pods per image.  (Or more simply, just list all pods and their associated image per project) 

2) Show a count of all images in use per OpenShift node.  (Or more simply, list pods and their associated imaged being run per node) 

In reports it is not possible to show a link between a pod and the image that it is running.  If you create a report and base it off of Projects, there is no way to select images.  The same is true if you base a report off of pods or containers.  

The below bugzilla is similar, but not entirely the same: 
https://bugzilla.redhat.com/show_bug.cgi?id=1297036



Version-Release number of selected component (if applicable):
CF 4.1 GA

Comment 2 Federico Simoncelli 2016-08-02 16:12:50 UTC
(In reply to Jon Jozwiak from comment #0)
> 2) Show a count of all images in use per OpenShift node.  (Or more simply,
> list pods and their associated imaged being run per node) 


Jon can you clarify better why you need that? ("count of all images in use per OpenShift node")

I'd understand an ask of "show a count of pods per OpenShift node", why instead you're focusing on images?

Thanks.

Comment 4 Jon Jozwiak 2016-08-09 13:01:24 UTC
It could also be a count of pods per node running a specific image.  The desire is for license or subscription-based products a customer can get a count of the nodes running a software (based on the image deployed).  They can then use that to understand how many physical systems are running that software for license compliance.

Comment 5 Federico Simoncelli 2016-08-11 14:03:22 UTC
Jon can you check if the screenshots here are satisfying the request of this BZ?

https://github.com/ManageIQ/manageiq/pull/10262

Thanks.

Comment 6 Jon Jozwiak 2016-08-16 17:34:07 UTC
I've provided some additional detail in PR10262 asking for: 

1) In the first screen shot, sort/count on image used per project vs count on all pods per project
2) On the second report, we should include image per pod. And sort/count per image per node image.

Comment 7 Federico Simoncelli 2016-09-05 16:57:37 UTC
(In reply to Jon Jozwiak from comment #6)
> I've provided some additional detail in PR10262 asking for: 
> 
> 1) In the first screen shot, sort/count on image used per project vs count
> on all pods per project
> 2) On the second report, we should include image per pod. And sort/count per
> image per node image.

Jon the discussion on the PR developed and it seems that without changes at the core of ManageIQ this is the best we can have at the moment:

https://github.com/ManageIQ/manageiq/pull/10262

given that in your initial description you said:

- ...Or more simply, just list all pods and their associated image per project

- ...Or more simply, list pods and their associated imaged being run per node

Would it be enough what we deliver in that PR?

Comment 8 Jaroslav Henner 2016-09-27 09:18:40 UTC
Currently the report looks like:

Project Name	Image Name	Pod Name
default	openshift3/jenkins-1-rhel7	jenkins-1-kv4ri
default	openshift3/jenkins-1-rhel7	jenkins-1-sss3s
default	openshift3/jenkins-1-rhel7	jenkins-1-mi14x
default	openshift3/jenkins-1-rhel7	jenkins-1-gfvkt
default	openshift3/jenkins-1-rhel7	jenkins-1-7822c
default	openshift3/jenkins-1-rhel7	jenkins-1-1d6s7
default	openshift3/jenkins-1-rhel7	jenkins-1-vj9g6
default	openshift3/jenkins-1-rhel7	jenkins-1-kyhrs
default	openshift3/jenkins-1-rhel7	jenkins-1-7lsio
default	openshift3/jenkins-1-rhel7	jenkins-1-7lf4h
default	openshift3/jenkins-1-rhel7	jenkins-1-748il
Name: default | Count: 11
 
management-infra	openshift3/image-inspector	manageiq-img-scan-f49b1
management-infra	openshift3/image-inspector	manageiq-img-scan-ea561
management-infra	openshift3/image-inspector	manageiq-img-scan-b7b91
management-infra	openshift3/image-inspector	manageiq-img-scan-a306f
management-infra	openshift3/image-inspector	manageiq-img-scan-9ac62
management-infra	openshift3/image-inspector	manageiq-img-scan-9abd5
management-infra	openshift3/image-inspector	manageiq-img-scan-991bc


It seems to contain much of duplicate information. The Project name and Image name is duplicated all over the place. I think it could be stated only once.

Also the pagination caused the footer of the management-infra project summary to remain in the next page which is quite inconvenient. I think there should be some indication of continuation of the table -- for example "...", or something like that.

Comment 9 CFME Bot 2016-11-08 21:51:06 UTC
New commit detected on ManageIQ/manageiq/euwe:
https://github.com/ManageIQ/manageiq/commit/3f840ef85eb45c7e6b7381f350de4b2259129199

commit 3f840ef85eb45c7e6b7381f350de4b2259129199
Author:     Oleg Barenboim <chessbyte@gmail.com>
AuthorDate: Tue Nov 8 16:42:59 2016 -0500
Commit:     Oleg Barenboim <chessbyte@gmail.com>
CommitDate: Tue Nov 8 16:43:29 2016 -0500

    Merge pull request #12327 from zeari/hide_chargeback_container_project
    
    Hide chargeback container image reports
    (cherry picked from commit 73a2aebb3c9c6876f76c06246e77ddcf3012156e)
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1357515

 lib/miq_expression.rb | 1 -
 1 file changed, 1 deletion(-)

Comment 11 Ari Zellner 2016-12-06 13:17:51 UTC
Jaroslav, this is the best we can do right now with these types of reports.
For additional generic features like having 'indication of continuation of the table' we should open separate bz's and examine them there.

Federico\jon, Can we move this to post?

Comment 13 Jaroslav Henner 2017-01-31 13:09:00 UTC
It looks broken. It seems it is doing a Cartesian product. project x project images x pods

It is visible even on the 
https://cloud.githubusercontent.com/assets/11256940/17407436/eec5d154-5a6f-11e6-8736-b4ed04656026.png
from one of the PRs (as well as on my latest CFME).

There is no way that management-metrics or docker registry would be runnning from haproxy-router which (IIUC) the linked picture shows.

Comment 14 Ari Zellner 2017-01-31 15:52:42 UTC
Jaroslav, you're correct.

Zahi and I looked at this and we couldn't find a solution that presents the requested data correctly with the current reporting mechanism.

We might have to remove this report entirely.

Comment 21 Federico Simoncelli 2017-05-26 15:06:34 UTC
(In reply to CFME Bot from comment #20)
> https://github.com/ManageIQ/manageiq/pull/15237

Libor I have the feeling that this PR is not related. Is it a Bot bug or was this BZ mentioned there somehow?

Comment 22 Libor Pichler 2017-05-26 16:10:37 UTC
Federico, 

yes it was accidentally added by the Bot(I had in PR some unwanted commits), the PR https://github.com/ManageIQ/manageiq/pull/15237 is not related to this BZ

Comment 23 Chris Pelland 2017-08-28 14:54:30 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 
If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.