Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357490 - libglusterfs : update correct memory segments in glfs-message-id
Summary: libglusterfs : update correct memory segments in glfs-message-id
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libglusterfsclient
Version: mainline
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Muthu Vigneshwaran
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-18 11:12 UTC by Muthu Vigneshwaran
Modified: 2017-03-27 18:15 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-27 18:15:01 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Muthu Vigneshwaran 2016-07-18 11:12:30 UTC
Description of problem:

In glfs-message-id the memory segment for JBR are not allocated properly.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vijay Bellur 2016-07-18 11:28:28 UTC
REVIEW: http://review.gluster.org/14942 (libglusterfs : update correct memory segments in glfs-message-id) posted (#1) for review on master by Anonymous Coward

Comment 2 Vijay Bellur 2016-07-18 16:28:43 UTC
COMMIT: http://review.gluster.org/14942 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 386340967926fa062e2c1eee4784f951846167b3
Author: Muthu-vigneshwaran <mvignesh@redhat.com>
Date:   Mon Jul 18 16:56:38 2016 +0530

    libglusterfs : update correct memory segments in glfs-message-id
    
    Change-Id: I669d6674e21d1524a2934edba8a77b70c77ef0f4
    BUG: 1357490
    Signed-off-by: Muthu-vigneshwaran <mvignesh@redhat.com>
    Reviewed-on: http://review.gluster.org/14942
    Tested-by: Muthu Vigneshwaran
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 3 Shyamsundar 2017-03-27 18:15:01 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.