Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357484 - [RFE] Consolidate messages in '1B. Update Availability', new environment paths
Summary: [RFE] Consolidate messages in '1B. Update Availability', new environment paths
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 1.0
Assignee: jmagen@redhat.com
QA Contact: Landon LaSmith
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-18 10:37 UTC by Antonin Pagac
Modified: 2016-09-13 16:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:32:01 UTC


Attachments (Terms of Use)
two messages, one green and one red (deleted)
2016-07-18 10:37 UTC, Antonin Pagac
no flags Details
adapter rejects the commit (deleted)
2016-07-18 10:38 UTC, Antonin Pagac
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC
Red Hat Bugzilla 1359328 None None None Never

Internal Links: 1359328

Description Antonin Pagac 2016-07-18 10:37:07 UTC
Description of problem:

 - when adding environment path with non-unique name after successfully adding another path will result in two messages, one green and one red. They are in different places, see screenshot. It would be better if the most recent message cleared all previous ones. Also better would be to show the messages in one place.

 - when adding more environment paths (I have added 13) the successful message as well as the error message are displayed on top of the page where user can't see them, because he has scrolled down to the 'New Environment Path' button. It would be better to somehow let user know, for example scroll up after adding new path, so the user can see the message, or otherwise display the message to user. It can be confusing when there is an error and user can't see the message about it.

 - when adding environment path with a number of trailing spaces, the label always converts the spaces to one underscore '_'. When trying to add more of these paths, there is an error:

'error saving environmentError: The adapter rejected the commit because it was invalid'

We should probably check for trailing spaces when adding new environment path.

Version-Release number of selected component (if applicable):
20160713.t.1

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Antonin Pagac 2016-07-18 10:37:47 UTC
Created attachment 1181015 [details]
two messages, one green and one red

Comment 2 Antonin Pagac 2016-07-18 10:38:22 UTC
Created attachment 1181016 [details]
adapter rejects the commit

Comment 4 jmagen@redhat.com 2016-07-19 12:35:09 UTC
This old PR was merged ahttps://github.com/fusor/fusor/pull/1036 and it fixed having a trailing "_" if there is whitespace

This new PR https://github.com/fusor/fusor/pull/1057 fixes remove the success message upon entering a 2nd lifecylcle environment. 

It also shows the error message under button "New Environment Path" so user doesn't need to scroll up

Comment 6 John Matthews 2016-07-20 22:52:13 UTC
QCI-1.2-RHEL-7-20160720.t.0-QCI-x86_64-dvd1.iso

Comment 10 Landon LaSmith 2016-07-22 20:41:58 UTC
VERIFIED. Error message was visible at the bottom of the screen and leading/trailing white space was trimmed properly then validated correctly

ISO Media version: QCI-1.2-RHEL-7-20160720.t.0

Comment 12 errata-xmlrpc 2016-09-13 16:32:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.