Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357480 - get_possible_orgs function never called?
Summary: get_possible_orgs function never called?
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 2.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jiří Dostál
QA Contact: Lukáš Hellebrandt
URL:
Whiteboard:
Depends On:
Blocks: 1395876 space27
TreeView+ depends on / blocked
 
Reported: 2016-07-18 10:19 UTC by Lukáš Hellebrandt
Modified: 2017-09-27 19:15 UTC (History)
4 users (show)

Fixed In Version: spacewalk-backend-2.6.12-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1395876 (view as bug list)
Environment:
Last Closed: 2017-09-27 19:15:07 UTC


Attachments (Terms of Use)
Patch removing the function (deleted)
2016-07-18 10:21 UTC, Lukáš Hellebrandt
no flags Details | Diff

Description Lukáš Hellebrandt 2016-07-18 10:19:28 UTC
I believe the function get_possible_orgs in backend/server/handlers/xmlrpc/registration.py is never called from clients. It used to be called by getPossibleOrgs function which has been removed by commit 867c6219d5ac1e722797f4846f5cbe32900f83a7. I can not find any other invocation of the function in the whole SW repo.

If I am right, I believe the function should be removed as it is not used by the supported clients.

Comment 1 Lukáš Hellebrandt 2016-07-18 10:21:41 UTC
Created attachment 1181012 [details]
Patch removing the function

Comment 2 Jiří Dostál 2016-07-18 13:26:16 UTC
spacewalk.git b7907dfe1d75d90d466b39a1e1b163b0a4ba5f35

Comment 3 Lukáš Hellebrandt 2016-11-11 13:25:19 UTC
Verified with SW nightly from 2016-11-11.

There is no getPossibleOrgs function in file /usr/share/rhn/server/handlers/xmlrpc/registration.py .
I also can not see any problem caused by its removal in automation.

Comment 4 Tomáš Kašpárek 2017-05-24 14:29:04 UTC
For you information the commit was reverted as it caused a regression in RHEL 5 clients registration.
spacewalk.git(master): c37dde2e39e576cb6fe07fd0133acad2caab098a

Comment 5 Eric Herget 2017-09-27 19:15:07 UTC
This looks like it was fixed in previous release, but I'm closing it in this one.

Spacewalk 2.7 has been released.

https://github.com/spacewalkproject/spacewalk/wiki/ReleaseNotes27


Note You need to log in before you can comment on or make changes to this bug.