Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357471 - upgrade failed on atomic hosts with docker 1.9.1
Summary: upgrade failed on atomic hosts with docker 1.9.1
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Upgrade
Version: 3.2.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Devan Goodwin
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-18 10:00 UTC by Anping Li
Modified: 2016-08-15 11:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-02 15:35:28 UTC


Attachments (Terms of Use)

Description Anping Li 2016-07-18 10:00:33 UTC
Description of problem:
Couldn't upgrade openshift if the docker 1.9.1 was included on atomic hosts. it show message "This playbook requires access to Docker 1.10 or later". 
Both docker 1.9.1 and docker 1.10.3 should be supported for Openshift 3.2. 

Version-Release number of selected component (if applicable):
openshift-ansible:master
atomic-openshift-utils-3.2.12-1.git.0.14b4bd0.el7.noarch

How reproducible:
always

Steps to Reproduce:
1) install Openshift 3.1.1.6 on atomic host
2) rebase atomioc hosts to version which included docker 1.9.1
3) run upgrade playbook

Actual results:
ASK: [fail ] ***************************************************************** 
<ha1node1.example.com> ESTABLISH CONNECTION FOR USER: root
failed: [ha1node1.example.com] => {"failed": true}
msg: This playbook requires access to Docker 1.10 or later
skipping: [ha1master1.example.com]
skipping: [ha1master2.example.com]
<ha1master3.example.com> ESTABLISH CONNECTION FOR USER: root
failed: [ha1master3.example.com] => {"failed": true}
msg: This playbook requires access to Docker 1.10 or later
skipping: [ha1node2.example.com]

Expected results:
The upgrade success. 

Additional info:

Comment 1 Scott Dodson 2016-08-02 15:35:28 UTC
Users need to upgrade to a newer version of atomic host.

Comment 2 Anping Li 2016-08-03 01:12:35 UTC
(In reply to Scott Dodson from comment #1)
> Users need to upgrade to a newer version of atomic host.

Will this be the prerequisite for upgrade on atomic hosts?  or just for OSE 3.1-> 3.2 upgrade?

As I see, 3.2 should be work with docker 1.9.1 and above?

Comment 3 Brenton Leanhardt 2016-08-03 11:47:37 UTC
Yes.  For atomic host systems we require the host to be upgraded first.  I can see how we don't make that very convenient for atomic host.  We can likely have the 3.3->3.4 upgrade handle this better by first evacuating the node and then checking the docker version.  If it's not up to date it can advise the admin to update to the latest ostree or perhaps just handle it itself.  I'm going to add this to the 3.4 upgrade card.


Note You need to log in before you can comment on or make changes to this bug.