Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357438 - manual page for git merge points to wrong path
Summary: manual page for git merge points to wrong path
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: git
Version: 26
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: ---
Assignee: pstodulk
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1471004 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-18 08:36 UTC by Jakub Jelen
Modified: 2017-08-06 22:25 UTC (History)
8 users (show)

Fixed In Version: git-2.13.4-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-06 22:25:42 UTC


Attachments (Terms of Use)

Description Jakub Jelen 2016-07-18 08:36:51 UTC
Description of problem:
Snippet from manual page:

NOTES
        1. revert-a-faulty-merge How-To
           file:///usr/share/doc/git/howto/revert-a-faulty-merge.html

The file is actually located in the 

    /usr/share/doc/git-core-doc/howto/revert-a-faulty-merge.html

Version-Release number of selected component (if applicable):
git-2.7.4-2.fc24.x86_64
git-2.7.4-1.fc24.x86_64
git-2.5.5-1.fc23.x86_64

How reproducible:
deterministic

Steps to Reproduce:
1. Check manual page for the above snippet
2. Check the real location of the documentation

Actual results:
The file is located elsewhere.

Expected results:
The link should work and be useful. Probably by fixing a manual page. There might be also other broken links, since the documentation is in a subpackage, with different path.

Comment 1 Villy Kruse 2017-07-15 08:05:31 UTC
Same error causing the command to fail.

$ git help --web help
fatal: '/usr/share/doc/git': not a documentation directory.

Tested on Fedora 26

Creating a symbolic link git --> git-core-doc is a work-around.

Comment 2 pstodulk 2017-07-17 18:36:21 UTC
*** Bug 1471004 has been marked as a duplicate of this bug. ***

Comment 3 Fedora End Of Life 2017-07-25 21:51:30 UTC
This message is a reminder that Fedora 24 is nearing its end of life.
Approximately 2 (two) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 24. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '24'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 24 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 4 Todd Zullinger 2017-07-25 21:54:06 UTC
A fix for this has been made in rawhide and we plan to push it to f26 shortly (possibly coinciding with git-2.13.4).

Comment 5 Fedora Update System 2017-08-01 23:14:27 UTC
git-2.13.4-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-965b1a5f8b

Comment 6 Villy Kruse 2017-08-02 06:01:59 UTC
$ git help --web help

Now works.   Problem solved.

Comment 7 Fedora Update System 2017-08-03 00:52:56 UTC
git-2.13.4-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-965b1a5f8b

Comment 8 Fedora Update System 2017-08-06 22:25:42 UTC
git-2.13.4-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.