Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357315 - TrackPoint click does not release
Summary: TrackPoint click does not release
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: libinput
Version: 24
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Benjamin Tissoires
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-18 02:34 UTC by Steven D.
Modified: 2017-08-08 15:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-08 15:39:49 UTC


Attachments (Terms of Use)
evemu-record on TrackPoint (deleted)
2016-07-19 02:12 UTC, Steven D.
no flags Details

Description Steven D. 2016-07-18 02:34:03 UTC
Description of problem:
Sometimes, when using my ThinkPad Yoga 12, a TrackPoint click does not release after I release the button.

This has something to do with the touchpad, since I can reproduce this issue by clicking and holding an item with the TrackPoint, placing three fingers on the touchpad, and releasing the TrackPoint button.

This problem occurs even if the touchpad is disabled in the Fedora settings.

I tried looking at the mouse events using xev. In the case described above, no release evng is seen.

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Click and hold something with the TrackPoint (a window for example)
2. Place three fingers on the touchpad without pressing the button (two fingers will not work)
3. Release the TrackPoint button

Actual results:
Mouse is not released

Expected results:
Mouse should be released

Additional info:
I will not have access to my Yoga 12 for much longer as I need to send it back to Lenovo. Let me know ASAP what information you need and I can give it.

Comment 1 Peter Hutterer 2016-07-18 03:14:19 UTC
sudo evemu-record against the trackpoint and then see if the events show up there. That should tell us if it's a userspace or kernel/hw bug.

Comment 2 Steven D. 2016-07-19 02:12:05 UTC
Created attachment 1181377 [details]
evemu-record on TrackPoint

As requested.

Corresponds to pressing and holding trackpoint button, placing three fingers on the touchpad, moving the trackpoint a bit while it was stuck pressed, and left clicking to restore the normal state.

Comment 3 Peter Hutterer 2016-07-21 00:42:25 UTC
right, this is an issue either in the kernel or (more likely) in the firmware. If you look at the output you can see a BTN_LEFT down at the beginning and then a BTN_LEFT up at the end. According to your summary there should be at least one more release + press in there somewhere.

Comment 4 Steven D. 2016-07-21 00:51:24 UTC
It would seem pressing-and-releasing the left button at the end is what triggered the final release. So if it's in the firmware it would have to be solved by a vendor upgrade then?

Comment 5 Benjamin Tissoires 2016-07-21 12:49:52 UTC
I am pretty sure we already have seen this bug, and the solution was to switch the Synaptics touchpad over RMI4. We can reproduce the exact same bug on the t450s while using PS/2, and not when using RMI4.

I am not sure a firmware upgrade will change anything, but we need to switch the device into an other mode to solve this. This switch takes time upstream but we will eventually fix it.

Comment 6 Steven D. 2016-07-22 03:34:18 UTC
Glad to hear it Benjamin, thanks. I finally had to return this device to Lenovo so I no longer have access to it. What should we do with this bug report?

Comment 7 Benjamin Tissoires 2016-07-22 06:56:55 UTC
(In reply to Steven D. from comment #6)
> What should we do with this bug report?

We should keep it open until the fix gets upstream. At that point we can include the patches as a pre-release in Fedora and we will close this bug as FIXED.

Comment 8 Peter Hutterer 2016-08-30 06:28:30 UTC
punting to benjamin so he keeps track of it :P

Comment 9 Fedora End Of Life 2017-07-25 21:51:11 UTC
This message is a reminder that Fedora 24 is nearing its end of life.
Approximately 2 (two) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 24. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '24'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 24 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 10 Fedora End Of Life 2017-08-08 15:39:49 UTC
Fedora 24 changed to end-of-life (EOL) status on 2017-08-08. Fedora 24 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.