Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357282 - Rebuilding of jss srpm fails when java-1.8.0-openjdk is used
Summary: Rebuilding of jss srpm fails when java-1.8.0-openjdk is used
Keywords:
Status: CLOSED DUPLICATE of bug 1289799
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: jss
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 7.3
Assignee: Matthew Harmsen
QA Contact: Asha Akkiangady
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-17 17:03 UTC by Asha Akkiangady
Modified: 2016-08-09 04:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-09 04:12:39 UTC


Attachments (Terms of Use)
Rebuilding of jss srpm with java-1.8.0-openjdk (deleted)
2016-07-17 17:03 UTC, Asha Akkiangady
no flags Details
javadocs patch (deleted)
2016-08-03 21:22 UTC, Matthew Harmsen
no flags Details | Diff
javadocs patch (spec file changes) (deleted)
2016-08-03 21:23 UTC, Matthew Harmsen
no flags Details

Description Asha Akkiangady 2016-07-17 17:03:21 UTC
Created attachment 1180810 [details]
Rebuilding of jss srpm with java-1.8.0-openjdk

Description of problem:
Rebuilding of jss srpm fails when java-1.8.0-openjdk is used.

Version-Release number of selected component (if applicable):
jss-4.2.6-41.el7

How reproducible:
Always

Steps to Reproduce:
1. Execute errata TPS tests for the srpm using java-1.8.0-openjdk.

Actual results:
Attached.

Expected results:
jss srpm should build successfully with java-1.8.0-openjdk.

Additional info:
With java-1.7.0-openjdk-1.7.0.101-2.6.6.1.el7_2 jss srpm rebuilds successfully.

Comment 1 Asha Akkiangady 2016-07-17 17:04:35 UTC
# alternatives --config javac

There are 3 programs which provide 'javac'.

  Selection    Command
-----------------------------------------------
   1           /usr/lib/jvm/java-1.8.0-ibm-1.8.0.3.0-1jpp.1.el7.x86_64/bin/javac
   2           /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.101-2.6.6.1.el7_2.x86_64/bin/javac
*+ 3           /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.91-1.b14.el7_2.x86_64/bin/javac

Comment 3 Matthew Harmsen 2016-08-03 21:22:32 UTC
Created attachment 1187215 [details]
javadocs patch

Comment 4 Matthew Harmsen 2016-08-03 21:23:48 UTC
Created attachment 1187216 [details]
javadocs patch (spec file changes)

Comment 5 Matthew Harmsen 2016-08-09 04:12:39 UTC
I have discovered the problem --- my patch is NOT needed!

The problem was that my patch was quite similar to Endi's patch that was missing from RHEL 7, and as a consequence would not apply since Endi's patch already fixed all of these issues.

So, please do the following:

    RHEL:
        * Add 'jss-Fixed-build-failures.patch' patch
        * jss.spec file diffs:
          * # diff jss.spec.orig SPECS/jss.spec
            3c3
            < Release:        41%{?dist}
            ---
            > Release:        42%{?dist}
            53,56c53,57
            < Patch29:        jss-VerifyCertificate-enhancement.patch
            < Patch30:        jss-lunasaUnwrap.patch
            < Patch31:        jss-symkey-enhancements.patch
            < Patch32:        jss-crmf-envelopedData.patch
            ---
            > Patch29:        jss-Fixed-build-failures.patch
            > Patch30:        jss-VerifyCertificate-enhancement.patch
            > Patch31:        jss-lunasaUnwrap.patch
            > Patch32:        jss-symkey-enhancements.patch
            > Patch33:        jss-crmf-envelopedData.patch
            104a106
            > %patch33 -p1
            208a211,213
            > * Mon Aug  8 2016 Matthew Harmsen <mharmsen@redhat.com> - 4.2.6-42
            > - Sync all patches from both Fedora and RHEL (cfu, edewata)
            >
    FEDORA:
        * Add 'jss-WindowsCompileFix.patch' and 'jss-WindowsLoadLibrary.patch'
          patches
        * jss.spec file diffs:
          * # diff jss.spec.orig SPECS/jss.spec
            3c3
            < Release:        41%{?dist}
            ---
            > Release:        42%{?dist}
            51,55c51,57
            < Patch27:        jss-Fixed-build-failures.patch
            < Patch28:        jss-VerifyCertificate-enhancement.patch
            < Patch29:        jss-lunasaUnwrap.patch
            < Patch30:        jss-symkey-enhancements.patch
            < Patch31:        jss-crmf-envelopedData.patch
            ---
            > Patch27:        jss-WindowsCompileFix.patch
            > Patch28:        jss-WindowsLoadLibrary.patch
            > Patch29:        jss-Fixed-build-failures.patch
            > Patch30:        jss-VerifyCertificate-enhancement.patch
            > Patch31:        jss-lunasaUnwrap.patch
            > Patch32:        jss-symkey-enhancements.patch
            > Patch33:        jss-crmf-envelopedData.patch
            103a106,107
            > %patch32 -p1
            > %patch33 -p1
            207a212,214
            > * Mon Aug  8 2016 Matthew Harmsen <mharmsen@redhat.com> - 4.2.6-42
            > - Sync all patches from both Fedora and RHEL (cfu, edewata)
            >

Rebuild on Koji jss/fc24, jss/fc25, and jss/master; rebuild on Brew jss/rhel-7.3.

*** This bug has been marked as a duplicate of bug 1289799 ***


Note You need to log in before you can comment on or make changes to this bug.