Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1357279 - redhat-rpm-config not listed as a dependency
Summary: redhat-rpm-config not listed as a dependency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: root
Version: 24
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Mattias Ellert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-17 16:22 UTC by adam.morris
Modified: 2016-08-04 23:21 UTC (History)
2 users (show)

Fixed In Version: root-6.06.06-2.fc24 root-6.06.06-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 18:54:21 UTC


Attachments (Terms of Use)
Terminal session demonstrating and fixing the bug (deleted)
2016-07-17 16:22 UTC, adam.morris
no flags Details

Description adam.morris 2016-07-17 16:22:11 UTC
Created attachment 1180783 [details]
Terminal session demonstrating and fixing the bug

Description of problem:

On a fresh Fedora 24 install, the root interpreter will not run properly without installing redhat-rpm-config

Version-Release number of selected component (if applicable):

6.06.04-4.fc24

Steps to Reproduce:
1. Install the package root 
2. run /usr/bin/root

Actual results:

ERROR in cling::CIFactory::createCI(): cannot extract standard library include paths!
Invoking:
    echo | LC_ALL=C c++ -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -mtune=generic  -pipe -m64 -Wall -W -Woverloaded-virtual -fsigned-char -fPIC -pthread -std=c++14 -Wno-deprecated-declarations -DR__HAVE_CONFIG -Wno-comment -Wno-unused-parameter -Wno-maybe-uninitialized -Wno-unused-but-set-variable -Wno-missing-field-initializers  -fPIC -fvisibility-inlines-hidden -std=c++1y -ffunction-sections -fdata-sections -fno-common -Woverloaded-virtual -Wcast-qual -fno-strict-aliasing -pedantic -Wno-long-long -Wall -W -Wno-unused-parameter -Wwrite-strings -Wno-unused-local-typedefs -O2 -DNDEBUG -xc++ -E -v - 2>&1 >/dev/null | awk '/^#include </,/^End of search/{if (!/^#include </ && !/^End of search/){ print }}' | grep -E "(c|g)\+\+"
results in
with exit code 256
input_line_1:1:10: fatal error: 'new' file not found
#include <new>
         ^
input_line_3:38:10: fatal error: 'string' file not found
#include <string>
         ^
input_line_8:1:10: fatal error: 'iostream' file not found
#include <iostream>
         ^
IncrementalExecutor::executeFunction: symbol '_ZN5cling7runtime6gClingE' unresolved while linking [cling interface function]!
You are probably missing the definition of cling::runtime::gCling
Maybe you need to load the corresponding shared library?
root [0]

Expected results:

******************************
*  Welcome to ROOT v6.06/04  *
******************************

root [0]

Additional info:

One of the flags is -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1, which is provided by the package redhat-rpm-config

Comment 1 Fedora Update System 2016-07-19 05:25:01 UTC
root-6.06.06-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-fcc7456b56

Comment 2 Fedora Update System 2016-07-19 05:25:08 UTC
root-6.06.06-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-fcc7456b56

Comment 3 Fedora Update System 2016-07-19 05:27:23 UTC
root-6.06.06-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-68a83da0f9

Comment 4 Fedora Update System 2016-07-20 01:20:52 UTC
root-6.06.06-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-fcc7456b56

Comment 5 Fedora Update System 2016-07-20 01:54:19 UTC
root-6.06.06-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-68a83da0f9

Comment 6 adam.morris 2016-07-20 12:42:48 UTC
Bug persists. The interpeter still calls a c++ command with `-specs=/usr/lib/rpm/redhat/redhat-hardened-cc1` (is this even necessary?)

Therefore I still have to manually install the package redhat-rpm-config to get root to run without error.

Comment 7 Mattias Ellert 2016-07-20 13:01:05 UTC
Which version did you test? 6.06.06-1 or 6.06.06-2?

root-cling-6.06.06-2 has a Requires on redhat-rpm-config:
https://koji.fedoraproject.org/koji/rpminfo?rpmID=7867551

Comment 8 adam.morris 2016-07-20 13:02:26 UTC
6.06.06-1 my bad, sorry.

Comment 9 Fedora Update System 2016-07-27 18:54:18 UTC
root-6.06.06-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2016-08-04 23:21:24 UTC
root-6.06.06-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.